summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-08-23 02:17:11 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-08-25 16:35:53 +0200
commit3444fb8b2c32c6b70d91e14675661f533207f827 (patch)
treef39ca1e13afb4c4c743a3cf556e7554a9c982435 /dev-qt/qtgamepad
parentdev-qt/qtplugininfo: Add dev-qt/qtxml to DEPEND (diff)
downloadgentoo-3444fb8b2c32c6b70d91e14675661f533207f827.tar.gz
gentoo-3444fb8b2c32c6b70d91e14675661f533207f827.tar.bz2
gentoo-3444fb8b2c32c6b70d91e14675661f533207f827.zip
dev-qt/qtgamepad: Fix IUSE=sdl to depend on media-libs/libsdl2
EAPI-8 Closes: https://bugs.gentoo.org/777516 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtgamepad')
-rw-r--r--dev-qt/qtgamepad/qtgamepad-5.15.2-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-qt/qtgamepad/qtgamepad-5.15.2-r1.ebuild b/dev-qt/qtgamepad/qtgamepad-5.15.2-r1.ebuild
new file mode 100644
index 000000000000..70434d09b66a
--- /dev/null
+++ b/dev-qt/qtgamepad/qtgamepad-5.15.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt5-build
+
+DESCRIPTION="Qt module to support gamepad hardware"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+IUSE="evdev qml sdl"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtgui-${PV}[evdev?]
+ evdev? ( virtual/libudev:= )
+ qml? ( ~dev-qt/qtdeclarative-${PV} )
+ sdl? ( media-libs/libsdl2 )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt_use_disable_mod qml quick \
+ src/src.pro
+
+ qt_use_disable_config evdev evdev \
+ src/plugins/gamepads/gamepads.pro
+
+ qt_use_disable_config sdl sdl2 \
+ src/plugins/gamepads/gamepads.pro
+
+ qt5-build_src_prepare
+}