summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-13 11:48:17 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-13 16:24:00 +0100
commitd787a0a50e63d45927951dccfd7cde7c445b18c1 (patch)
tree319447839039a679d47bd72045deb6a03b6905af /dev-python
parentbsdmk.eclass: Last rite (diff)
downloadgentoo-d787a0a50e63d45927951dccfd7cde7c445b18c1.tar.gz
gentoo-d787a0a50e63d45927951dccfd7cde7c445b18c1.tar.bz2
gentoo-d787a0a50e63d45927951dccfd7cde7c445b18c1.zip
dev-python/hypothesis: Drop old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-4.51.0.ebuild58
2 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index dd931af7b0b8..ced45a1ed0c7 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -4,5 +4,4 @@ DIST hypothesis-python-4.15.0.tar.gz 1175925 BLAKE2B f3e3888b3f4e542d567bdaad258
DIST hypothesis-python-4.44.2.tar.gz 3240386 BLAKE2B 3fe3295ba1f7401e1fb74af894d91eda525f8ef51eb893f1f8e5224cead8572f3c06f6a4bb345c123e56ed06d0676c85dc4477a80e54480baa6bd9f5f2bc069e SHA512 bebc5da337fa74a75d08cb57531c2f6b8ba1ab16d1a3d9be8348cd56ada1ab25a34e3b812a4aa71bf172bc97ebc8df0accdad37466f9162c3f8f2a8edbea9da9
DIST hypothesis-python-4.47.5.tar.gz 6805022 BLAKE2B 737a558c794f3ac428bef4b38858d47fddba613ce37eb9a9554afa3c189776e9172965dd31f8497747ac13b2ab1d34ee6de8671646972e71b82c5260db489b9a SHA512 9b6920181dca75b9e551ae5e598101f35cfc26e9e3a1b20cab652c151bc6355413d0c9602d3242fb23f808ab00335793009df938d55ee19a6af1ce2a8b085e3c
DIST hypothesis-python-4.50.8.tar.gz 6814518 BLAKE2B f2c39cae3708fe88d1854cda97633ba420c32fda38093bb852ef45929762cade0f7f0d1ef696ff96f7ebe7460e8bf53f63de9c959bbbd9e8ec162196d307aac0 SHA512 8c77439fd029e2380afbc059d2edf977414997ba81ecdfde14dfe9dbe9515a92e701751d13879c6b879271f817e01926c2dc66945ae76eb141818da1775bc545
-DIST hypothesis-python-4.51.0.tar.gz 6814862 BLAKE2B 706badd24f7185ba0b2c07f98f9a48dec449d05464b81510f84e2c540a8d272a9c24e50e766b757537c7cc91190e843b0c5204a5e8688c377b0ee456eb201643 SHA512 f350cef9413dafc919808ab0131278790b3f19aac7f54a414207a5c16fb73d81edd7accb29b5977c77ab583d464e7fcab882e5ac68760740466248de6b783001
DIST hypothesis-python-4.53.1.tar.gz 6815720 BLAKE2B 6a569bdb003efd4fe12f074ec15b5a7d5d92af3ffadd9a7cecc8cb4eaa9ecc4ef206151408c7c78617235658c9725f3e5fe6b33668757e74dbf0c8640ac141a4 SHA512 56839be12656d5a970e0d9b97ec3e7b8aa600b88bfb53d09c09270ccf5abcf5f25ec7c33b01c5c30a1a5450903b919dbff2b1e709937000ebcf434235310a8c9
diff --git a/dev-python/hypothesis/hypothesis-4.51.0.ebuild b/dev-python/hypothesis/hypothesis-4.51.0.ebuild
deleted file mode 100644
index 3def9e851218..000000000000
--- a/dev-python/hypothesis/hypothesis-4.51.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
-PYTHON_REQ_USE="threads(+),sqlite"
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="A library for property based testing"
-HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
-SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' pypy)
-"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- >=dev-python/pytest-4.3[${PYTHON_USEDEP}]
- !!<dev-python/typing-3.7.4.1
- )
-"
-
-S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
-
-src_prepare() {
- # avoid pytest-xdist dep for one test
- sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
- tests/pytest/test_statistics.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local pyver=$(python_is_python3 && echo 3 || echo 2)
- pytest -vv tests/cover tests/pytest tests/py${pyver} ||
- die "Tests fail with ${EPYTHON}"
-}
-
-pkg_postinst() {
- optfeature "datetime support" dev-python/pytz
- optfeature "dateutil support" dev-python/python-dateutil
- optfeature "numpy support" dev-python/numpy
- optfeature "django support" dev-python/django dev-python/pytz
- optfeature "pandas support" dev-python/pandas
- optfeature "pytest support" dev-python/pytest
-}