summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-03 08:48:06 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-03 09:51:34 +0200
commita63d05f0f6f4e9fe1e7025330197ee2592d2ec5b (patch)
treeb29cb8215885f1236309ac7a8063e85a29902667 /dev-python
parentdev-python/lmfit: Bump to 1.2.1 (diff)
downloadgentoo-a63d05f0f6f4e9fe1e7025330197ee2592d2ec5b.tar.gz
gentoo-a63d05f0f6f4e9fe1e7025330197ee2592d2ec5b.tar.bz2
gentoo-a63d05f0f6f4e9fe1e7025330197ee2592d2ec5b.zip
dev-python/klein: Bump to 23.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/klein/Manifest1
-rw-r--r--dev-python/klein/klein-23.5.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/klein/Manifest b/dev-python/klein/Manifest
index 5b57ead8ae3a..501170634d41 100644
--- a/dev-python/klein/Manifest
+++ b/dev-python/klein/Manifest
@@ -1 +1,2 @@
DIST klein-21.8.0.tar.gz 100578 BLAKE2B ea2535e93affebe822ff086eb5749481edf7811340a35b11319b7c23b23d3877f6208ac1ef6cc7a4bb9eedd33d087820304f2ee71695413d72308e83c47aa2ee SHA512 cce28865e172effb6044f73c1841875fa5eb55daf20dcea482d0764604ab826ca5063a4679165bb253953d54428a42c2082022fd273e2a1083aefa595a563ccd
+DIST klein-23.5.0.tar.gz 100691 BLAKE2B 913f48d975ef94787da910f217e687046e6d60273aac455eecae89378742cb7533ff5ab0a8ad868d5b363f27af1d0ee68f3b17a16b51482b5e4c015e7a779b53 SHA512 10d7bb1a5aabc035aa69a0f9c25516ee9b6043f442b35b31f5687c249370e4674c4488a9531ff4bc06ea40574fd9a7974343899de3d5b3895f28a2feb70ae543
diff --git a/dev-python/klein/klein-23.5.0.ebuild b/dev-python/klein/klein-23.5.0.ebuild
new file mode 100644
index 000000000000..115b81d4d0d5
--- /dev/null
+++ b/dev-python/klein/klein-23.5.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Micro-framework for developing production-ready web services with Python"
+HOMEPAGE="
+ https://pypi.org/project/klein/
+ https://github.com/twisted/klein/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ >=dev-python/attrs-20.1.0[${PYTHON_USEDEP}]
+ dev-python/hyperlink[${PYTHON_USEDEP}]
+ dev-python/incremental[${PYTHON_USEDEP}]
+ dev-python/tubes[${PYTHON_USEDEP}]
+ >=dev-python/twisted-16.6[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/treq[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest