summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-14 07:44:50 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-14 07:59:47 +0100
commita34775ef4d02743258035df1ebda1b808cafa3a5 (patch)
treebdea01ce655e61e9dd8bcb59e2429e4e8c9b91df /dev-python
parentdev-python/django-debug-toolbar: Bump to 5.0.1 (diff)
downloadgentoo-a34775ef4d02743258035df1ebda1b808cafa3a5.tar.gz
gentoo-a34775ef4d02743258035df1ebda1b808cafa3a5.tar.bz2
gentoo-a34775ef4d02743258035df1ebda1b808cafa3a5.zip
dev-python/tagpy: Bump to 2025.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/tagpy/Manifest1
-rw-r--r--dev-python/tagpy/tagpy-2025.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/tagpy/Manifest b/dev-python/tagpy/Manifest
index cae7e14312ac..18621be5bf11 100644
--- a/dev-python/tagpy/Manifest
+++ b/dev-python/tagpy/Manifest
@@ -1 +1,2 @@
DIST tagpy-2022.1.gh.tar.gz 198744 BLAKE2B 1a0722017ae532444cf97171c04964453bdb6c427a49bace4ad9fe3a3be9be7f0903a9ae3fb8dbf0c8450112ed5f83677044c6b2546dddec3550d8251cef4cff SHA512 d740bf17abe6a2a7cd7fe037c024c8361d49d2ec4e8d03dbdc27c9ec273696b0a41d087a7159692e9b849e807af493f68239562da01d5191bee95060b32aabda
+DIST tagpy-2025.1.gh.tar.gz 256974 BLAKE2B 629dc6b4dd980040e2a248b2ca55a4dc1f90e5dde214602dd80c68fc55a864c34ea3e1c7849185b04a13b66eace7b865054d667f0edb007b9eb479df2b5aae19 SHA512 9842c1bcf2ca9d3ba554d1771e7296280fe9b2749fe834ddc8045fc9587b5acc2705019f0065839690b3f65f9e4e2fab42d14e0f1267367fbf446993517e3531
diff --git a/dev-python/tagpy/tagpy-2025.1.ebuild b/dev-python/tagpy/tagpy-2025.1.ebuild
new file mode 100644
index 000000000000..d7db5a0aabc2
--- /dev/null
+++ b/dev-python/tagpy/tagpy-2025.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Bindings for TagLib"
+HOMEPAGE="
+ https://github.com/palfrey/tagpy/
+ https://pypi.org/project/tagpy/
+"
+SRC_URI="
+ https://github.com/palfrey/tagpy/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ dev-libs/boost:=[python,${PYTHON_USEDEP}]
+ media-libs/taglib:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests pytest