summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <chr@chymera.eu>2022-03-24 16:35:01 -0400
committerMichał Górny <mgorny@gentoo.org>2022-03-25 15:39:38 +0100
commita183683045c675b5f0faddd099d9aed4761401c2 (patch)
treeedf930c0b9105b659bb96eb7002240e4324befb2 /dev-python
parentdev-python/uri_template: new package, v1.1.0 (diff)
downloadgentoo-a183683045c675b5f0faddd099d9aed4761401c2.tar.gz
gentoo-a183683045c675b5f0faddd099d9aed4761401c2.tar.bz2
gentoo-a183683045c675b5f0faddd099d9aed4761401c2.zip
dev-python/jsonschema: dependency update
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Horea Christian <chr@chymera.eu> Closes: https://github.com/gentoo/gentoo/pull/24181 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jsonschema/jsonschema-4.4.0-r2.ebuild50
-rw-r--r--dev-python/jsonschema/metadata.xml2
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-python/jsonschema/jsonschema-4.4.0-r2.ebuild b/dev-python/jsonschema/jsonschema-4.4.0-r2.ebuild
new file mode 100644
index 000000000000..43c4398c2ee1
--- /dev/null
+++ b/dev-python/jsonschema/jsonschema-4.4.0-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of JSON-Schema validation for Python"
+HOMEPAGE="
+ https://pypi.org/project/jsonschema/
+ https://github.com/python-jsonschema/jsonschema/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ >=dev-python/pyrsistent-0.18.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_resources-1.4.0[${PYTHON_USEDEP}]
+ ' 3.8)
+"
+
+# formatter deps
+RDEPEND+="
+ dev-python/fqdn[${PYTHON_USEDEP}]
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/isoduration[${PYTHON_USEDEP}]
+ >=dev-python/jsonpointer-1.13[${PYTHON_USEDEP}]
+ dev-python/rfc3339-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3986-validator[${PYTHON_USEDEP}]
+ dev-python/rfc3987[${PYTHON_USEDEP}]
+ dev-python/uri_template[${PYTHON_USEDEP}]
+ >=dev-python/webcolors-1.11[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires pip, does not make much sense for the users
+ jsonschema/tests/test_cli.py::TestCLIIntegration::test_license
+ # wtf?
+ jsonschema/tests/test_deprecations.py::TestDeprecations::test_version
+)
diff --git a/dev-python/jsonschema/metadata.xml b/dev-python/jsonschema/metadata.xml
index bb56d4b870fe..6c4a82118957 100644
--- a/dev-python/jsonschema/metadata.xml
+++ b/dev-python/jsonschema/metadata.xml
@@ -16,6 +16,6 @@ Python (supporting 2.6+ including Python 3).
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">jsonschema</remote-id>
- <remote-id type="github">Julian/jsonschema</remote-id>
+ <remote-id type="github">python-jsonschema/jsonschema</remote-id>
</upstream>
</pkgmetadata>