summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-04-01 13:03:41 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-04-01 14:04:06 -0700
commit9cda95ce84a81dae1b5c631068f5a4925736cecb (patch)
treebb328351799df4bbc89f772bc5ae837cf74c6cc7 /dev-python
parentmedia-libs/sratom: arm64 stable (bug #706052) (diff)
downloadgentoo-9cda95ce84a81dae1b5c631068f5a4925736cecb.tar.gz
gentoo-9cda95ce84a81dae1b5c631068f5a4925736cecb.tar.bz2
gentoo-9cda95ce84a81dae1b5c631068f5a4925736cecb.zip
dev-python/threadpoolctl: New package
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/threadpoolctl/Manifest1
-rw-r--r--dev-python/threadpoolctl/metadata.xml11
-rw-r--r--dev-python/threadpoolctl/threadpoolctl-2.0.0.ebuild23
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/threadpoolctl/Manifest b/dev-python/threadpoolctl/Manifest
new file mode 100644
index 000000000000..f6f9348b4134
--- /dev/null
+++ b/dev-python/threadpoolctl/Manifest
@@ -0,0 +1 @@
+DIST threadpoolctl-2.0.0.tar.gz 23349 BLAKE2B d7752d862f8de5d61a95dd2e0db9a9cf5b3fde4c13cad9f654c0af4e2277b8bcc36b79028fbdf0e14af35daacee4b01a8778462364e070eaa194af65f4274739 SHA512 8ce823a6aef9f6d6af73e848c7a3bb1c7eee3f94bf480ca056ed5f435655756b9ad26cb71e392689cd8e6a34ee1ddfcf0d8510e424ac9c05bb1eda679d0f7a93
diff --git a/dev-python/threadpoolctl/metadata.xml b/dev-python/threadpoolctl/metadata.xml
new file mode 100644
index 000000000000..2541628cf9a8
--- /dev/null
+++ b/dev-python/threadpoolctl/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/threadpoolctl/threadpoolctl-2.0.0.ebuild b/dev-python/threadpoolctl/threadpoolctl-2.0.0.ebuild
new file mode 100644
index 000000000000..ae4251fa5508
--- /dev/null
+++ b/dev-python/threadpoolctl/threadpoolctl-2.0.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="Limit the number of threads used in native libs that have their own threadpool"
+HOMEPAGE="https://github.com/joblib/threadpoolctl"
+SRC_URI="https://github.com/joblib/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+# tests require openmp python bindings...
+RESTRICT=test
+
+distutils_enable_tests pytest