summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2025-01-16 05:47:40 +0100
committerMichał Górny <mgorny@gentoo.org>2025-01-16 06:10:59 +0100
commit756530b2da9bbba884851881a8c7b9ab3030f76f (patch)
treeb8909fa3c45796e9d9bc116e99e72bad19c92de9 /dev-python
parentdev-python/psycopg: Remove old (diff)
downloadgentoo-756530b2da9bbba884851881a8c7b9ab3030f76f.tar.gz
gentoo-756530b2da9bbba884851881a8c7b9ab3030f76f.tar.bz2
gentoo-756530b2da9bbba884851881a8c7b9ab3030f76f.zip
dev-python/sphinxygen: Bump to 1.0.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinxygen/Manifest1
-rw-r--r--dev-python/sphinxygen/sphinxygen-1.0.6.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/sphinxygen/Manifest b/dev-python/sphinxygen/Manifest
index 8a610b47e5d2..7323c231749b 100644
--- a/dev-python/sphinxygen/Manifest
+++ b/dev-python/sphinxygen/Manifest
@@ -1 +1,2 @@
DIST sphinxygen-v1.0.4.tar.bz2 16224 BLAKE2B 6b06e015bc04a445b2f1983be193b2a17296c263efccb7a67a06e73c4f06d312d3cd103e6493c428d1ee5fb3058309b50cb066e8f988145edf3705181ab3c658 SHA512 54872ead6725aa41057347b5cf45285411db90266266f8805d34dc846d0a0a69c013f894958721238b1eb7f7c9d13e105bbd4e7d5afe50eaaf17bad6d4f46662
+DIST sphinxygen-v1.0.6.tar.bz2 16583 BLAKE2B e9838b66de1575fdb884978a2b33e0d5b4585063b9d3cd52ca464bbaf4af56af26fa264916564c54bfcdc36603d87648037a2b8c129f53a294b312e7e7a20c3d SHA512 298a7017480a51e29dd3f74d3615bb931175635a9169b7aa308eacd51cfa274a6504e9231f08b7e71fcd00ca2d18086030b4805cb4ad4517ea43c1b8ab0e1111
diff --git a/dev-python/sphinxygen/sphinxygen-1.0.6.ebuild b/dev-python/sphinxygen/sphinxygen-1.0.6.ebuild
new file mode 100644
index 000000000000..a23270e7f581
--- /dev/null
+++ b/dev-python/sphinxygen/sphinxygen-1.0.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python module/script that generates Sphinx markup to describe a C API"
+HOMEPAGE="
+ https://gitlab.com/drobilla/sphinxygen/
+ https://pypi.org/project/sphinxygen/
+"
+SRC_URI="
+ https://gitlab.com/drobilla/sphinxygen/-/archive/v${PV}/${PN}-v${PV}.tar.bz2
+"
+S="${WORKDIR}/${PN}-v${PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ app-text/doxygen
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest