summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-03 06:53:54 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-03 07:23:18 +0200
commit673dee68fbc10ff4b8ebb0d9d75c1cc284ef3885 (patch)
tree38e389283e9acb86c7963d0d56841da0c27b1fdf /dev-python
parentdev-python/watchdog: Bump to 5.0.1 (diff)
downloadgentoo-673dee68fbc10ff4b8ebb0d9d75c1cc284ef3885.tar.gz
gentoo-673dee68fbc10ff4b8ebb0d9d75c1cc284ef3885.tar.bz2
gentoo-673dee68fbc10ff4b8ebb0d9d75c1cc284ef3885.zip
dev-python/apprise: Bump to 1.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/apprise/Manifest1
-rw-r--r--dev-python/apprise/apprise-1.9.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/apprise/Manifest b/dev-python/apprise/Manifest
index dac209227bae..c5ccd1905d8b 100644
--- a/dev-python/apprise/Manifest
+++ b/dev-python/apprise/Manifest
@@ -1 +1,2 @@
DIST apprise-1.8.1.tar.gz 1696426 BLAKE2B ddc8966716e89a3e18995370e90f20c080a1249faccdbcf5f28fb22a89dc3f415c33208a5c98352307a28a65b45e305d1b9c3e2df52f6f6f017197a6f893a101 SHA512 b0e5d760ad8fcbecaa51de8e398abbb8766ef8a52bbd9cbd7f77156e4e00194adc1e18e0b6a95c611863ae72162041971408744348a7ea9e6579f4f4aae15f04
+DIST apprise-1.9.0.tar.gz 1753505 BLAKE2B 83dda79cb585387ba3fa0405126274c35bee20e40a91e699441f56341f411e16dd62ff73115e6cde42e0184afffcaa4cb0783e082d0b2c1ed59a58839cfe9c73 SHA512 9b1ebc18f1662cea35186ddf28182e5507d7faf6e13770a4d6448f129c9d4659665ddf502e0cc7e6bd2e67cda41ee94cd0898f53b986af0daae5f905ccdab2eb
diff --git a/dev-python/apprise/apprise-1.9.0.ebuild b/dev-python/apprise/apprise-1.9.0.ebuild
new file mode 100644
index 000000000000..d6fb609e2b6c
--- /dev/null
+++ b/dev-python/apprise/apprise-1.9.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Push Notifications that work with just about every platform"
+HOMEPAGE="
+ https://pypi.org/project/apprise/
+ https://github.com/caronc/apprise/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv"
+IUSE="+dbus mqtt"
+
+RDEPEND="
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
+ mqtt? ( dev-python/paho-mqtt[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ dev-python/Babel[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest