summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-03-09 18:51:23 -0800
committerPatrick McLean <chutzpah@gentoo.org>2022-03-09 18:51:23 -0800
commit3454d2d96bbb0ee1755f42cd1827cb02296dd200 (patch)
tree96338e34a19c67b47dac4492a59a064265369dd0 /dev-python
parentapp-admin/sysklogd: keyword ~riscv, #834866 (diff)
downloadgentoo-3454d2d96bbb0ee1755f42cd1827cb02296dd200.tar.gz
gentoo-3454d2d96bbb0ee1755f42cd1827cb02296dd200.tar.bz2
gentoo-3454d2d96bbb0ee1755f42cd1827cb02296dd200.zip
dev-python/pyparted: Version bump to 3.12.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pyparted/Manifest1
-rw-r--r--dev-python/pyparted/pyparted-3.12.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pyparted/Manifest b/dev-python/pyparted/Manifest
index 0e3383b1f6b8..f1ffba2f7a2b 100644
--- a/dev-python/pyparted/Manifest
+++ b/dev-python/pyparted/Manifest
@@ -1 +1,2 @@
DIST pyparted-3.11.7.tar.gz 105671 BLAKE2B ffe7869c7ac85f291314d0381e18ca6a732eca2cee3d31fe31a89b8b1c1c671f97a06a586f235ee67244388ab214a7e51c67951a5c1eb79fb1b448f6a004381c SHA512 147fdc45d47faaee574a7b0268a218eef49be929a147d20adf85cc0302d94e57e98e02072591ca035cad7efe164e7dd87bd1a31504f5cff8575f18d4469dc2b0
+DIST pyparted-3.12.0.tar.gz 106440 BLAKE2B 824223e385a6f1bfd9c01dc4c665ddeca5b73bbc2e65a9ade8086393f3dc0ebdc11528beabe7eeec8d0b8172b49db15ad8c34425efe4db47439f1b5617f9c55c SHA512 c1779c16868799bbff0905ea908db668823d1c238b9a06bcd62b24f9681fdd1e9378e904a91eb5e426a6e264cf1f2feee984a514e9098bf10147643bf58aa918
diff --git a/dev-python/pyparted/pyparted-3.12.0.ebuild b/dev-python/pyparted/pyparted-3.12.0.ebuild
new file mode 100644
index 000000000000..2496d9e96f86
--- /dev/null
+++ b/dev-python/pyparted/pyparted-3.12.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for sys-block/parted"
+HOMEPAGE="https://github.com/dcantrell/pyparted/"
+SRC_URI="https://github.com/dcantrell/pyparted/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ >=sys-block/parted-3.4
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ test? ( dev-python/six[${PYTHON_USEDEP}] )
+ virtual/pkgconfig
+"
+
+distutils_enable_tests unittest