summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-14 18:33:54 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-14 18:33:54 +0200
commit7cd077138bdce17211ae13f77a27055d2a385833 (patch)
treecd869531e8f1714e6de7829459fd7e15ad3cff32 /dev-python/xarray
parentdev-python/httpx-socks: Enable py3.13 (diff)
downloadgentoo-7cd077138bdce17211ae13f77a27055d2a385833.tar.gz
gentoo-7cd077138bdce17211ae13f77a27055d2a385833.tar.bz2
gentoo-7cd077138bdce17211ae13f77a27055d2a385833.zip
dev-python/xarray: Deselect tests broken on 32-bit arches
Closes: https://bugs.gentoo.org/933710 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xarray')
-rw-r--r--dev-python/xarray/xarray-2024.5.0.ebuild11
-rw-r--r--dev-python/xarray/xarray-2024.6.0.ebuild11
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/xarray/xarray-2024.5.0.ebuild b/dev-python/xarray/xarray-2024.5.0.ebuild
index 230618ae0dc5..0407fe0f8e37 100644
--- a/dev-python/xarray/xarray-2024.5.0.ebuild
+++ b/dev-python/xarray/xarray-2024.5.0.ebuild
@@ -69,6 +69,17 @@ python_test() {
)
fi
+ if [[ ${ABI} != *64* ]]; then
+ EPYTEST_DESELECT+=(
+ # these tests hardcode object sizes for 64-bit arches
+ # https://github.com/pydata/xarray/issues/9127
+ xarray/tests/test_dataarray.py::TestDataArray::test_repr_multiindex
+ xarray/tests/test_dataarray.py::TestDataArray::test_repr_multiindex_long
+ xarray/tests/test_dataset.py::TestDataset::test_repr_multiindex
+ xarray/tests/test_formatting.py::test_array_repr_dtypes_unix
+ )
+ fi
+
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest
}
diff --git a/dev-python/xarray/xarray-2024.6.0.ebuild b/dev-python/xarray/xarray-2024.6.0.ebuild
index 4c9c99624526..3253f14b00d9 100644
--- a/dev-python/xarray/xarray-2024.6.0.ebuild
+++ b/dev-python/xarray/xarray-2024.6.0.ebuild
@@ -69,6 +69,17 @@ python_test() {
)
fi
+ if [[ ${ABI} != *64* ]]; then
+ EPYTEST_DESELECT+=(
+ # these tests hardcode object sizes for 64-bit arches
+ # https://github.com/pydata/xarray/issues/9127
+ xarray/tests/test_dataarray.py::TestDataArray::test_repr_multiindex
+ xarray/tests/test_dataarray.py::TestDataArray::test_repr_multiindex_long
+ xarray/tests/test_dataset.py::TestDataset::test_repr_multiindex
+ xarray/tests/test_formatting.py::test_array_repr_dtypes_unix
+ )
+ fi
+
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest
}