summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-12 13:42:22 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-12 13:42:41 +0200
commit2bed9f4e2c7af2ad1ecb7ebf727e1058f193952c (patch)
treee666ff182b9df030b1e32584a055fe5959e5ba6c /dev-python/xarray
parentnet-proxy/haproxy: Bump to 2.0.22 (diff)
downloadgentoo-2bed9f4e2c7af2ad1ecb7ebf727e1058f193952c.tar.gz
gentoo-2bed9f4e2c7af2ad1ecb7ebf727e1058f193952c.tar.bz2
gentoo-2bed9f4e2c7af2ad1ecb7ebf727e1058f193952c.zip
dev-python/xarray: Deselect failing warning test
Closes: https://bugs.gentoo.org/779403 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xarray')
-rw-r--r--dev-python/xarray/xarray-0.17.0.ebuild9
1 files changed, 9 insertions, 0 deletions
diff --git a/dev-python/xarray/xarray-0.17.0.ebuild b/dev-python/xarray/xarray-0.17.0.ebuild
index 894b1d80800a..f797bf1c514c 100644
--- a/dev-python/xarray/xarray-0.17.0.ebuild
+++ b/dev-python/xarray/xarray-0.17.0.ebuild
@@ -31,3 +31,12 @@ BDEPEND="
)"
distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # warning-targeted tests are fragile and not important to end users
+ xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
+ )
+
+ epytest ${deselect[@]/#/--deselect }
+}