summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-05 05:51:27 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-05 05:51:27 +0100
commit2a68dc61d1311faf67e8f07e751979202f70db8a (patch)
tree873916f778870d1bc64e7a1d6b02f111e3e31b24 /dev-python/wrapt
parentdev-python/wrapt: Add USE=native-extensions (diff)
downloadgentoo-2a68dc61d1311faf67e8f07e751979202f70db8a.tar.gz
gentoo-2a68dc61d1311faf67e8f07e751979202f70db8a.tar.bz2
gentoo-2a68dc61d1311faf67e8f07e751979202f70db8a.zip
dev-python/wrapt: Bump to 1.16.0_rc2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/wrapt')
-rw-r--r--dev-python/wrapt/Manifest1
-rw-r--r--dev-python/wrapt/wrapt-1.16.0_rc2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/wrapt/Manifest b/dev-python/wrapt/Manifest
index 87d06d5c2675..a37355f46103 100644
--- a/dev-python/wrapt/Manifest
+++ b/dev-python/wrapt/Manifest
@@ -1 +1,2 @@
DIST wrapt-1.15.0.gh.tar.gz 137402 BLAKE2B 8c4764251a89f7795fef71dd71d9c36611d896d2e2791a5e7ce4f665f7b477e683f21aa05251a6ceb96644221a7ff9b01dfe98a7f4d278987dedc17ead39b343 SHA512 6be3fc6380e6bb11a26e35fb093ca54d2e851ab384682f6b1201599980c0429c1e2f23089540b66dd80985baaaf3fb93ce29034758e062e2cfb2f52e3b362779
+DIST wrapt-1.16.0rc2.gh.tar.gz 138531 BLAKE2B fc6c573a80ab5a5f82b3e0dc60ecce34642361982b00d4066d84eb186cc2dc2542769205674f74370aff98b252acb65e7013f181c75da3e7389d3bdfe1ff6971 SHA512 f6b6a2a34c6f5c285e08411b2fca2464e21028776595e821e09cfc45da9519b88911fa74d47952de365a7625322672d025fd66be1393238ff776dd6b84cd8aa2
diff --git a/dev-python/wrapt/wrapt-1.16.0_rc2.ebuild b/dev-python/wrapt/wrapt-1.16.0_rc2.ebuild
new file mode 100644
index 000000000000..2941453acf76
--- /dev/null
+++ b/dev-python/wrapt/wrapt-1.16.0_rc2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/_}
+DESCRIPTION="Module for decorators, wrappers and monkey patching"
+HOMEPAGE="
+ https://github.com/GrahamDumpleton/wrapt/
+ https://pypi.org/project/wrapt/
+"
+SRC_URI="
+ https://github.com/GrahamDumpleton/wrapt/archive/${PV/_}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+native-extensions"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+
+python_compile() {
+ local -x WRAPT_INSTALL_EXTENSIONS=$(usex native-extensions true false)
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}