summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-08 06:32:38 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-08 06:49:11 +0200
commit246e4ef445f9b2d6b6b6ff07f2574a8b6957db4e (patch)
treee375641c3f1a9dcc8404ef4b6631689bf41fa513 /dev-python/uv
parentdev-python/pymongo: Bump to 4.7.2 (diff)
downloadgentoo-246e4ef445f9b2d6b6b6ff07f2574a8b6957db4e.tar.gz
gentoo-246e4ef445f9b2d6b6b6ff07f2574a8b6957db4e.tar.bz2
gentoo-246e4ef445f9b2d6b6b6ff07f2574a8b6957db4e.zip
dev-python/uv: Bump to 0.1.41
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/uv')
-rw-r--r--dev-python/uv/Manifest2
-rw-r--r--dev-python/uv/uv-0.1.41.ebuild121
2 files changed, 123 insertions, 0 deletions
diff --git a/dev-python/uv/Manifest b/dev-python/uv/Manifest
index f2d1a804f3ff..c0ce2af5ae5d 100644
--- a/dev-python/uv/Manifest
+++ b/dev-python/uv/Manifest
@@ -7,3 +7,5 @@ DIST uv-0.1.24.gh.tar.gz 899637 BLAKE2B fab26ba9934fc5f586505b5ac1fa386c11f07e51
DIST uv-0.1.38-crates.tar.xz 65881140 BLAKE2B c1a640c44d73d5607c8d07468cefc66c150135b0f0249362148bd2b8f8c99a43c9031a642c0f76140631177df947be7637b49e99e247afbd7efbebb2ad79bcb1 SHA512 99bf6f341f9e6cf8eb0834c436b81453615725cabd3ddc4cca34edb307200bdbb71e913e8ff52a2a1d11e5f1a4abfb4dbdfe40a9c4f114079a7d9fdace0bcaab
DIST uv-0.1.38.gh.tar.gz 1023332 BLAKE2B e62259084fc9122d311bbcac754796b9e0ac28f4865755e03729eb6ad5adab4f9e3f77c41af1dbdbdc3a55d5a4736875aa26ddc7b78b745c8d6fb4d6b8bbd959 SHA512 7dad22d038aad03ad72ee0c5fdb77ccfbf56fc94a38613373a037eb26c2f228bc6c883d542621b45f2a55c8d51b7345fdd919dc1db45aa4d598e368311c72fdd
DIST uv-0.1.39.gh.tar.gz 1026174 BLAKE2B 857e3f3dd81fae33244bbae5b7e124886ee8c57576f57e5264fb11b89fcb842e18ec07756e70204dc28be0e02ac0368c238d69ae5b1c0a95ab07416a6cf1ccff SHA512 6454fde2eb5166c2097fb44c4b8f505d27344a4a63589589de402887a57c8e1aeed5d52c7e892530d16de9d4a187b6b423f70550016d3c233cec8300b81a8b34
+DIST uv-0.1.41-crates.tar.xz 65965588 BLAKE2B 350a4e9e5d3a41682844d7f5e2824f262ef78dab7329723b65c1605c064601d0680c89d194e0228597043d66ae4fd70eb3b20433a42c29668af284c75044d281 SHA512 60f99aee7ee8660565bb3d44694e7eb897599a5b6f11fc6af771b00ee66911a8f0d9117ad61c152e56fc40137edd9f5cc0d1726c9158544adbc8c9b52dbe4384
+DIST uv-0.1.41.gh.tar.gz 1069659 BLAKE2B 9caa7c282fa9626510c9f736dfd1796d2e33238378dad1de2c468f745e914b75d7346ecf8ee6d4a87de82b86b3fee5260d95bf0c526c14b96bce44bc983e5758 SHA512 ea8a2b0cd15f3276404c2b8e00ec700346bc2839e3dc7806e537f94bd600818e479fbe3928e1047436382a7caa3d0792fef5f83cfc243ed42018e58a1bee1e6f
diff --git a/dev-python/uv/uv-0.1.41.ebuild b/dev-python/uv/uv-0.1.41.ebuild
new file mode 100644
index 000000000000..9fc32bfd4abf
--- /dev/null
+++ b/dev-python/uv/uv-0.1.41.ebuild
@@ -0,0 +1,121 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+"
+
+declare -A GIT_CRATES=(
+ [async_zip]='https://github.com/charliermarsh/rs-async-zip;1dcb40cfe1bf5325a6fd4bfcf9894db40241f585;rs-async-zip-%commit%'
+ [pubgrub]='https://github.com/astral-sh/pubgrub;c26e485213e39582c6f2e4d45c0328422670e7a7;pubgrub-%commit%'
+)
+
+inherit cargo check-reqs
+
+CRATE_P=${P}
+DESCRIPTION="A Python package installer and resolver, written in Rust"
+HOMEPAGE="
+ https://github.com/astral-sh/uv/
+ https://pypi.org/project/uv/
+"
+# pypi sdist misses scripts/, needed for tests
+SRC_URI="
+ https://github.com/astral-sh/uv/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ ${CARGO_CRATE_URIS}
+"
+if [[ ${PKGBUMPING} != ${PVR} ]]; then
+ SRC_URI+="
+ https://dev.gentoo.org/~mgorny/dist/${CRATE_P}-crates.tar.xz
+ "
+fi
+
+# most of the code
+LICENSE="|| ( Apache-2.0 MIT )"
+# crates/pep508-rs is || ( Apache-2.0 BSD-2 ) which is covered below
+# Dependent crate licenses
+LICENSE+="
+ 0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD-2 BSD ISC MIT
+ MPL-2.0 Unicode-DFS-2016
+"
+# ring crate
+LICENSE+=" openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="test"
+PROPERTIES="test_network"
+
+DEPEND="
+ dev-libs/libgit2:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=virtual/rust-1.77
+ test? (
+ dev-lang/python:3.8
+ dev-lang/python:3.9
+ dev-lang/python:3.10
+ dev-lang/python:3.11
+ dev-lang/python:3.12
+ )
+"
+
+QA_FLAGS_IGNORED="usr/bin/.*"
+
+check_space() {
+ local CHECKREQS_DISK_BUILD=3G
+ use debug && CHECKREQS_DISK_BUILD=9G
+ check-reqs_pkg_setup
+}
+
+pkg_pretend() {
+ check_space
+}
+
+pkg_setup() {
+ check_space
+}
+
+src_prepare() {
+ default
+
+ # https://github.com/vorot93/tokio-tar/pull/23
+ # (fortunately uv already depends on portable-atomic, so we don't
+ # have to fight Cargo.lock)
+ cd "${WORKDIR}/cargo_home/gentoo/tokio-tar-0.3.1" || die
+ eapply "${FILESDIR}/tokio-tar-0.3.1-ppc.patch"
+}
+
+src_configure() {
+ local myfeatures=(
+ # from upstream defaults
+ flate2/zlib-ng
+ python
+ pypi
+ git
+ maturin
+ # skip tests that require specific patch version of the interpreter:
+ # python-patch
+ )
+
+ cargo_src_configure --no-default-features
+}
+
+src_compile() {
+ cd crates/uv || die
+ cargo_src_compile
+}
+
+src_test() {
+ cd crates/uv || die
+ cargo_src_test --no-fail-fast
+}
+
+src_install() {
+ cd crates/uv || die
+ cargo_src_install
+}