summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-24 19:42:48 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-24 19:42:48 +0200
commitcd02c2253dcb1a51c6d3209b65f6d7ac1db134b2 (patch)
treec5b9a43cb225d041bf1449553f903cd726a269b2 /dev-python/typed-ast
parentapp-arch/lunzip: New package, v1.13 (diff)
downloadgentoo-cd02c2253dcb1a51c6d3209b65f6d7ac1db134b2.tar.gz
gentoo-cd02c2253dcb1a51c6d3209b65f6d7ac1db134b2.tar.bz2
gentoo-cd02c2253dcb1a51c6d3209b65f6d7ac1db134b2.zip
dev-python/typed-ast: add 1.5.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/typed-ast')
-rw-r--r--dev-python/typed-ast/Manifest1
-rw-r--r--dev-python/typed-ast/typed-ast-1.5.2.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/typed-ast/Manifest b/dev-python/typed-ast/Manifest
index d21aa5d5e06d..fdc1d265e03b 100644
--- a/dev-python/typed-ast/Manifest
+++ b/dev-python/typed-ast/Manifest
@@ -1,2 +1,3 @@
DIST typed_ast-1.4.3.tar.gz 210893 BLAKE2B 9e0bbaac73d97c13303c783d4e91b015570d9b9ad74361e1bcfe67259982459003ea6c24602ce004fe1447c4375090d5fa58006e18af28da256f6b25d9aa20b1 SHA512 7ac06e277c883afd1a7161601ffca0114aa63db257695a4bf4c64d819a7192fe52167edb57991aefc7accc6a9902b5faf2ba9e4032c4b9be31f1db7a091607c9
DIST typed_ast-1.5.1.tar.gz 252316 BLAKE2B 4bb2987cc84277a595c8297563f257e495a4b298885f54b82ce177f5ce610809f462d0022a549e83c4c991e441720f36bd2451eef3487fc68ceda76b845a01d2 SHA512 9e1b1e5da242f29c52857a5a683be47d95b592c788a7c603fc38f637ee64f687253aa58994061681c703addd2405532dfdc0765dd1cadf16b339623901f61355
+DIST typed_ast-1.5.2.tar.gz 252310 BLAKE2B c36ab31e4c266de38a07935fc72ece62087bc52a6ebde401f9b2dcc641af064828572fa6e903dbdfb0c573ced10686b8dba995d316a5f7a7ee68efd3a4e9520c SHA512 7da72fc0c4fcb74cb41914765baea5c7f52b1e8a5c58883877e702765be59d3dd8c7f73bd5759a65781d04fdecbcf46160ff4402578a92685f25163e12b93558
diff --git a/dev-python/typed-ast/typed-ast-1.5.2.ebuild b/dev-python/typed-ast/typed-ast-1.5.2.ebuild
new file mode 100644
index 000000000000..8a0f2077cd67
--- /dev/null
+++ b/dev-python/typed-ast/typed-ast-1.5.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Python typed-ast backported"
+HOMEPAGE="https://pypi.org/project/typed-ast/ https://github.com/python/typed_ast"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN/-/_}/${P/-/_}.tar.gz"
+S="${WORKDIR}/${P/-/_}"
+
+LICENSE="Apache-2.0 MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ epytest
+}