summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-04 17:11:59 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-04 19:03:13 +0100
commit63a7c5fbd185a843547669d20e1956cc8a1488e8 (patch)
treebf5262f42152a11a06a1addbb26b885093301557 /dev-python/tubes
parentdev-python/twython: Enable py3.12 (diff)
downloadgentoo-63a7c5fbd185a843547669d20e1956cc8a1488e8.tar.gz
gentoo-63a7c5fbd185a843547669d20e1956cc8a1488e8.tar.bz2
gentoo-63a7c5fbd185a843547669d20e1956cc8a1488e8.zip
dev-python/tubes: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tubes')
-rw-r--r--dev-python/tubes/tubes-0.2.1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-python/tubes/tubes-0.2.1.ebuild b/dev-python/tubes/tubes-0.2.1.ebuild
index 4b6ba32fdcb3..657e9f7ed22a 100644
--- a/dev-python/tubes/tubes-0.2.1.ebuild
+++ b/dev-python/tubes/tubes-0.2.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
@@ -28,3 +28,11 @@ RDEPEND="
"
distutils_enable_tests pytest
+
+src_prepare() {
+ # fix tests on py3.12
+ # https://github.com/twisted/tubes/pull/95
+ sed -i -e 's:assertEquals:assertEqual:' tubes/test/*.py || die
+
+ distutils-r1_src_prepare
+}