summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-12 09:19:48 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-12 09:27:50 +0200
commit621295830d8ac696ebeabcfca75f63c5edf4a1d2 (patch)
treeabc2b21da57e93b0b29aaa4746df5e0f3e382cda /dev-python/translate-toolkit
parentdev-python/pyproject-metadata: Remove old (diff)
downloadgentoo-621295830d8ac696ebeabcfca75f63c5edf4a1d2.tar.gz
gentoo-621295830d8ac696ebeabcfca75f63c5edf4a1d2.tar.bz2
gentoo-621295830d8ac696ebeabcfca75f63c5edf4a1d2.zip
dev-python/translate-toolkit: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/translate-toolkit')
-rw-r--r--dev-python/translate-toolkit/Manifest1
-rw-r--r--dev-python/translate-toolkit/translate-toolkit-3.13.3.ebuild119
2 files changed, 0 insertions, 120 deletions
diff --git a/dev-python/translate-toolkit/Manifest b/dev-python/translate-toolkit/Manifest
index e9b80b99cfe4..d88627b68f76 100644
--- a/dev-python/translate-toolkit/Manifest
+++ b/dev-python/translate-toolkit/Manifest
@@ -1,3 +1,2 @@
-DIST translate-3.13.3.gh.tar.gz 1172858 BLAKE2B e7b2f711faec3876fdc082aae02716beaa45934f2ad308433c20020e69b72850e0a9d32c7cb57e32b4fdc8b39334a358b8f289c83744882728616122f07cf8f7 SHA512 f435306b34a2a200df5b648a1354444ac5fd76872f36062704b2c8abf52b8b1e1d570afbcf4b50cb1d815abfcf85b05630e8bc02f908a83f3fea90188c76c6f7
DIST translate-3.13.4.gh.tar.gz 1173494 BLAKE2B 878da77378e4ca1a27c3053812b4f70c1decc55523421daa1716f10c4af9cc1d3d1a601bf076f343eaf34c661355af84dc2d173411779942e83eb4d7e64280f9 SHA512 44d0ee7d5e8b177034385bbc323539b8d53ef7a01d2431ea9c58a8df24ccc5f55af15f245b584db225e194b796d0281dec73ed66f50f8749cf949cb0a4c95277
DIST translate-3.13.5.gh.tar.gz 1173710 BLAKE2B 1b6431cb0ce2643477c352f54dff0b7cbac8a79d3bf1e2a5976cdea649f8bbf3ee23f96ee97db1c5a7e57789ca5b434cddac959aeda92acaa75a0714b04bc507 SHA512 5ae243584f2bc4e3b304c6e0ccba2f4fcd3728964ed8361017241a787124dc24580ec842b3116036cd99f911f066e29559291b56893410f170d59f1e722e81a2
diff --git a/dev-python/translate-toolkit/translate-toolkit-3.13.3.ebuild b/dev-python/translate-toolkit/translate-toolkit-3.13.3.ebuild
deleted file mode 100644
index 525771d408ee..000000000000
--- a/dev-python/translate-toolkit/translate-toolkit-3.13.3.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-MY_P=translate-${PV}
-DESCRIPTION="Toolkit to convert between many translation formats"
-HOMEPAGE="
- https://github.com/translate/translate/
- https://pypi.org/project/translate-toolkit/
-"
-SRC_URI="
- https://github.com/translate/translate/archive/${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S="${WORKDIR}"/${MY_P}
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86"
-IUSE="+html +ical +ini +subtitles +yaml"
-
-RDEPEND="
- app-text/iso-codes
- >=dev-python/chardet-3.0.4[${PYTHON_USEDEP}]
- dev-python/cheroot[${PYTHON_USEDEP}]
- >=dev-python/Levenshtein-0.12.0[${PYTHON_USEDEP}]
- >=dev-python/lxml-4.3.1[${PYTHON_USEDEP}]
- >=dev-python/mistletoe-1.1.0[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-3[${PYTHON_USEDEP}]
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
- >=dev-python/wcwidth-0.2.10[${PYTHON_USEDEP}]
- sys-devel/gettext
- html? ( dev-python/utidylib[${PYTHON_USEDEP}] )
- ical? ( dev-python/vobject[${PYTHON_USEDEP}] )
- ini? ( >=dev-python/iniparse-0.5[${PYTHON_USEDEP}] )
- subtitles? ( media-video/gaupol[${PYTHON_USEDEP}] )
- yaml? ( dev-python/pyyaml[${PYTHON_USEDEP}] )
-"
-# Technically, the test suite also has undeclared dependency
-# on dev-python/snapshottest but all the tests using it are broken
-# anyway, so we skip them.
-BDEPEND="
- test? (
- dev-python/phply[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_test() {
- # unfortunately, this bad quality package doesn't support XDG_DATA_DIRS
- # correctly, so we need to reassemble all data files in a single directory
- local -x XDG_DATA_HOME=${T}/share
- cp -r translate/share "${T}/" || die
- cp -r "${ESYSROOT}/usr/share"/gaupol "${XDG_DATA_HOME}"/ || die
-
- distutils-r1_src_test
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Fails with network-sandbox (and even with it off but w/ softer fail)
- 'tests/xliff_conformance/test_xliff_conformance.py::test_open_office_to_xliff'
- 'tests/xliff_conformance/test_xliff_conformance.py::test_po_to_xliff'
- # all tests based on snapshottest are broken and I'm too tired
- # to figure this out
- tests/translate/tools/test_pocount.py::test_{cases,output}
- tests/translate/tools/test_junitmsgfmt.py::test_output
- )
- local EPYTEST_IGNORE=(
- # unpackaged fluent.*
- tests/translate/storage/test_fluent.py
- # changes directory and does not change it back, sigh
- tests/odf_xliff/test_odf_xliff.py
- )
-
- if ! use ini; then
- EPYTEST_IGNORE+=(
- translate/convert/test_ini2po.py
- translate/convert/test_po2ini.py
- )
- fi
-
- if ! use subtitles; then
- EPYTEST_IGNORE+=(
- translate/storage/test_subtitles.py
- )
- fi
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- insinto /usr
- doins -r translate/share
-
- if ! use html; then
- rm "${ED}"/usr/bin/{html2po,po2html} || die
- fi
- if ! use ical; then
- rm "${ED}"/usr/bin/{ical2po,po2ical} || die
- fi
- if ! use ini; then
- rm "${ED}"/usr/bin/{ini2po,po2ini} || die
- fi
- if ! use subtitles; then
- rm "${ED}"/usr/bin/{sub2po,po2sub} || die
- fi
-}