summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-07 16:49:40 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-07 16:52:37 +0200
commit77e885e9086bd4b56191173918508573a14a6470 (patch)
treeb2f1cc79e7003fa41d38b9a6948447b4ed1166e1 /dev-python/tqdm
parentdev-python/sentry-sdk: Remove old (diff)
downloadgentoo-77e885e9086bd4b56191173918508573a14a6470.tar.gz
gentoo-77e885e9086bd4b56191173918508573a14a6470.tar.bz2
gentoo-77e885e9086bd4b56191173918508573a14a6470.zip
dev-python/tqdm: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/tqdm')
-rw-r--r--dev-python/tqdm/Manifest1
-rw-r--r--dev-python/tqdm/files/tqdm-4.61.1-py310.patch35
-rw-r--r--dev-python/tqdm/tqdm-4.61.1.ebuild55
3 files changed, 0 insertions, 91 deletions
diff --git a/dev-python/tqdm/Manifest b/dev-python/tqdm/Manifest
index f051406858c8..d70efdee269e 100644
--- a/dev-python/tqdm/Manifest
+++ b/dev-python/tqdm/Manifest
@@ -1,3 +1,2 @@
-DIST tqdm-4.61.1.tar.gz 169637 BLAKE2B 8b89f320e13119b24a9e121747bce0b5c6625c31feb8c427a97e71da52797d9de764ce5e5c41c07d5954a1e5e4e21913335a4691837bc243db473821b2dad1ac SHA512 6092a30389380a511abc8bee7e6144556d6dc1a993ba4a2685707afa2838a12f472aa216ac5e55d144da74f9be1d398d4c6f5352986a200557e4aba67831a505
DIST tqdm-4.61.2.tar.gz 169665 BLAKE2B f5dff67eb549cab0dd667815c25f6e885a2e0cefc2ad68e97fdc09599eb41b13589f7a88d5a445813973454a5e5f835b3139651ec2e09b717db0fd6dc705890e SHA512 bc33e8fe00244f90f61ab51d0c7c0b98d5580efebd9758284d9dbe2a699eabeb0d92871eedc2f95f377e29dd0f7ea4b5247b96cb4cc1687dcfea3a9ed1152ab7
DIST tqdm-4.62.0.tar.gz 169668 BLAKE2B 64a3df2f00a4fcba6bb67ae15e04f392a73b54cf7284f3c013ad31d00317e9d84ac2e1feed302137aeb7ea9e3c9d1d730623cbd96e8c76c46df6382435146efa SHA512 dd60d5522b68086410ec5f02574477dcc33a887ef509cc1d1735921dd906f951180d6115680517b3abbd2cf6c4ee1c60b9c950654ea9b7642d52d28052326088
diff --git a/dev-python/tqdm/files/tqdm-4.61.1-py310.patch b/dev-python/tqdm/files/tqdm-4.61.1-py310.patch
deleted file mode 100644
index 10cb898d4809..000000000000
--- a/dev-python/tqdm/files/tqdm-4.61.1-py310.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From d2a6ec2ab84aec847b1598bb2a777103cea7fc9f Mon Sep 17 00:00:00 2001
-From: Casper da Costa-Luis <tqdm@cdcl.ml>
-Date: Sat, 12 Jun 2021 17:39:37 +0100
-Subject: [PATCH] fix py3.10 `asyncio` tests
-
-- fixes #1176
----
- tqdm/asyncio.py | 7 ++++++-
- 1 file changed, 6 insertions(+), 1 deletion(-)
-
-diff --git a/tqdm/asyncio.py b/tqdm/asyncio.py
-index 0d3ba747d..8f9b4ed6e 100644
---- a/tqdm/asyncio.py
-+++ b/tqdm/asyncio.py
-@@ -8,6 +8,7 @@
- ... ...
- """
- import asyncio
-+from sys import version_info
-
- from .std import tqdm as std_tqdm
-
-@@ -60,7 +61,11 @@ def as_completed(cls, fs, *, loop=None, timeout=None, total=None, **tqdm_kwargs)
- """
- if total is None:
- total = len(fs)
-- yield from cls(asyncio.as_completed(fs, loop=loop, timeout=timeout),
-+
-+ kwargs = {}
-+ if version_info[:2] < (3, 10):
-+ kwargs['loop'] = loop
-+ yield from cls(asyncio.as_completed(fs, timeout=timeout, **kwargs),
- total=total, **tqdm_kwargs)
-
- @classmethod
diff --git a/dev-python/tqdm/tqdm-4.61.1.ebuild b/dev-python/tqdm/tqdm-4.61.1.ebuild
deleted file mode 100644
index f9721f3b05fa..000000000000
--- a/dev-python/tqdm/tqdm-4.61.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/tqdm/tqdm"
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86 ~x64-macos"
-fi
-
-DESCRIPTION="Add a progress meter to your loops in a second"
-HOMEPAGE="https://github.com/tqdm/tqdm"
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="examples"
-
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]
- dev-python/toml[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/${P}-py310.patch
-)
-
-python_test() {
- # Skip unpredictable performance tests
- epytest --ignore 'tests/tests_perf.py'
-}
-
-python_install() {
- doman "${BUILD_DIR}"/lib/tqdm/tqdm.1
- rm "${BUILD_DIR}"/lib/tqdm/tqdm.1 || die
- distutils-r1_python_install
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
- distutils-r1_python_install_all
-}