summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-17 06:53:15 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-17 07:02:40 +0100
commit6d10f420ec7e2c2bfe0779aea1417a54ed27b32a (patch)
tree2ae1866ef9378d8039cbab12d4b9f3342bc0419d /dev-python/thriftpy2
parentdev-python/stripe: Bump to 5.0.0 (diff)
downloadgentoo-6d10f420ec7e2c2bfe0779aea1417a54ed27b32a.tar.gz
gentoo-6d10f420ec7e2c2bfe0779aea1417a54ed27b32a.tar.bz2
gentoo-6d10f420ec7e2c2bfe0779aea1417a54ed27b32a.zip
dev-python/thriftpy2: Bump to 0.4.16
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/thriftpy2')
-rw-r--r--dev-python/thriftpy2/Manifest1
-rw-r--r--dev-python/thriftpy2/thriftpy2-0.4.16.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/thriftpy2/Manifest b/dev-python/thriftpy2/Manifest
index dc299c54ec7e..4b11b2c1160f 100644
--- a/dev-python/thriftpy2/Manifest
+++ b/dev-python/thriftpy2/Manifest
@@ -1 +1,2 @@
DIST thriftpy2-0.4.15.gh.tar.gz 136581 BLAKE2B 68287057e76ec6f2b91d9fca9a63e1814e2e17f4fb074b5f227b177137452f88921adf4912c66fee206b29d9f32cd0eb43cbbbe275574c21babc12b1f949672e SHA512 c5a17e42ac8a4051714938a4db926a25f41c84e4935fcf18c62ef8b115d9a1df3853800ca6c9fa01cafd6cbdfe31b6b4eabc7a81169a4773e0bda2241c4a26fb
+DIST thriftpy2-0.4.16.gh.tar.gz 146991 BLAKE2B 7547ea85106d0929d3e6ee771ff10ad2cd047f4e779c668e4a30ee936ac04d470e16d8321a2771db4404f57e1be41438b4a302bc04b8e4698db03de35dbfa5e9 SHA512 c00b21eb7db3fe91843a5129d16e7af2a29331489e7d8394bcf78eb5c4b8054162b9c5a024eec8080708dbffc491db7922258ecd895477cda49dcc7d56297ecf
diff --git a/dev-python/thriftpy2/thriftpy2-0.4.16.ebuild b/dev-python/thriftpy2/thriftpy2-0.4.16.ebuild
new file mode 100644
index 000000000000..856239dd1ed6
--- /dev/null
+++ b/dev-python/thriftpy2/thriftpy2-0.4.16.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python approach of Apache Thrift"
+HOMEPAGE="
+ https://github.com/Thriftpy/thriftpy2/
+ https://pypi.org/project/thriftpy2/
+"
+SRC_URI="
+ https://github.com/Thriftpy/thriftpy2/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/tornado[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ tests/test_tornado.py::TornadoRPCTestCase::test_asynchronous_exception
+ tests/test_tornado.py::TornadoRPCTestCase::test_asynchronous_result
+ )
+
+ cd tests || die
+ epytest
+}