summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-07 06:27:26 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-07 06:43:25 +0200
commit93915f3f97ecb1e3bf097f509387bece23cd0cb5 (patch)
tree2f6602362da2b6c91d5f953630eeb10dfbefd7c6 /dev-python/termcolor
parentdev-python/simsimd: Bump to 5.6.0 (diff)
downloadgentoo-93915f3f97ecb1e3bf097f509387bece23cd0cb5.tar.gz
gentoo-93915f3f97ecb1e3bf097f509387bece23cd0cb5.tar.bz2
gentoo-93915f3f97ecb1e3bf097f509387bece23cd0cb5.zip
dev-python/termcolor: Bump to 2.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/termcolor')
-rw-r--r--dev-python/termcolor/Manifest1
-rw-r--r--dev-python/termcolor/termcolor-2.5.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/termcolor/Manifest b/dev-python/termcolor/Manifest
index b290d3416c14..afe1a609a1b6 100644
--- a/dev-python/termcolor/Manifest
+++ b/dev-python/termcolor/Manifest
@@ -1 +1,2 @@
DIST termcolor-2.4.0.py.tar.gz 12664 BLAKE2B e5cf8f3ce1d27ffc0128cd9c1e38323e1e579a7a4017254a1d03c5f5baf0fa897522134ea68929c2e492b933fe8a6c3d79b55cb674fa3af134445581d870bf85 SHA512 e715940ccc8863baae020345cabc8fc90b5bbbd5ef4b384de96920a90d97508cee6f863aa39a2c08971e58f45cf85ec73c0659715f54072bbc57612681138355
+DIST termcolor-2.5.0.py.tar.gz 13057 BLAKE2B de67e0bca53daca32816cc4eff4f48d41c6e7a61d96892a050fd19fce95d9ed1fbc664a512a70ae91ffd40303780a293a1a793005b1b7779767e2d884126d5ca SHA512 2ef98f82387cc251f6762df7eb103407c52d3dc55d76c71dbf618c38a5c01e12803e8d6fa38f1ec8042ab373b79723e12ef642c18d4b126790a4a3a393ea0917
diff --git a/dev-python/termcolor/termcolor-2.5.0.ebuild b/dev-python/termcolor/termcolor-2.5.0.ebuild
new file mode 100644
index 000000000000..f1e102666cdb
--- /dev/null
+++ b/dev-python/termcolor/termcolor-2.5.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="ANSI Color formatting for output in terminal"
+HOMEPAGE="
+ https://github.com/termcolor/termcolor/
+ https://pypi.org/project/termcolor/
+"
+# rename is for avoiding conflict with dev-cpp/termcolor
+SRC_URI="$(pypi_sdist_url) -> ${P}.py.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest