summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-24 06:36:47 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-24 07:57:15 +0200
commit47e4e00199780eb515e249a6c721097992b7150d (patch)
treee1644b947afa9e2235c05ce034e9ceb8a101c7ff /dev-python/termcolor
parentdev-python/zeroconf: Bump to 0.58.0 (diff)
downloadgentoo-47e4e00199780eb515e249a6c721097992b7150d.tar.gz
gentoo-47e4e00199780eb515e249a6c721097992b7150d.tar.bz2
gentoo-47e4e00199780eb515e249a6c721097992b7150d.zip
dev-python/termcolor: Bump to 2.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/termcolor')
-rw-r--r--dev-python/termcolor/Manifest1
-rw-r--r--dev-python/termcolor/termcolor-2.3.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/termcolor/Manifest b/dev-python/termcolor/Manifest
index 6dc282158890..a7ca2cd56fdb 100644
--- a/dev-python/termcolor/Manifest
+++ b/dev-python/termcolor/Manifest
@@ -1 +1,2 @@
DIST python-termcolor-2.2.0.tar.gz 11340 BLAKE2B c1a7119bf4b6a137784e1b395d65ce2222e78c3747d1198b0c3407a15b02aa2f0343a12ac067696f19e94b4add0f8968164223f77cc79ffb703601003b8ce8fd SHA512 24a686c6589a56d2ae9ef9a974dc2308d23e9dcbc586df2c2e6ce938f4a6d85bcd20e4ecafcdee8b5b859917defd2965804e10ef761ce7929dc44826f0fca402
+DIST termcolor-2.3.0.py.tar.gz 12163 BLAKE2B a500cc13b0a7d43c32981f82408491c6fd30e489c1729bdbecae6e13e9deefe4a54944da56a241bc5c5f5411abfc2671dab8bc3ae23adf907f7eba617223f308 SHA512 0ccfd9320235215b85ddbf099399aaa325dd7176be7a39225377a81c372f9733105dcfe4a9e577cdca451be1f9b5538a071fc511bccd226fe0c4cbecb536bbf3
diff --git a/dev-python/termcolor/termcolor-2.3.0.ebuild b/dev-python/termcolor/termcolor-2.3.0.ebuild
new file mode 100644
index 000000000000..9cbfe7932985
--- /dev/null
+++ b/dev-python/termcolor/termcolor-2.3.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="ANSI Color formatting for output in terminal"
+HOMEPAGE="
+ https://github.com/termcolor/termcolor/
+ https://pypi.org/project/termcolor/
+"
+# rename is for avoiding conflict with dev-cpp/termcolor
+SRC_URI="$(pypi_sdist_url) -> ${P}.py.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest