summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-16 06:39:07 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-16 07:04:47 +0100
commit8fcf58f520250b861e186df46caf471925d5225c (patch)
treeecac6d2125c3513a14db2aa6f53219afd4c6d5d3 /dev-python/sympy
parentsci-visualization/yt: Remove Python 2 (diff)
downloadgentoo-8fcf58f520250b861e186df46caf471925d5225c.tar.gz
gentoo-8fcf58f520250b861e186df46caf471925d5225c.tar.bz2
gentoo-8fcf58f520250b861e186df46caf471925d5225c.zip
dev-python/sympy: Remove Python 2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sympy')
-rw-r--r--dev-python/sympy/sympy-1.0-r1.ebuild29
-rw-r--r--dev-python/sympy/sympy-1.3.ebuild26
-rw-r--r--dev-python/sympy/sympy-1.5.1.ebuild26
-rw-r--r--dev-python/sympy/sympy-1.5.ebuild26
4 files changed, 8 insertions, 99 deletions
diff --git a/dev-python/sympy/sympy-1.0-r1.ebuild b/dev-python/sympy/sympy-1.0-r1.ebuild
index ee681475875f..a1b4f8b591ef 100644
--- a/dev-python/sympy/sympy-1.0-r1.ebuild
+++ b/dev-python/sympy/sympy-1.0-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_6,3_7} )
+PYTHON_COMPAT=( python{3_6,3_7} )
inherit distutils-r1 eutils virtualx
@@ -14,15 +14,13 @@ SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples gtk imaging ipython latex mathml opengl pdf png pyglet test texmacs theano"
+IUSE="examples gtk imaging ipython latex mathml opengl pdf png test texmacs"
RESTRICT="!test? ( test )"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
- doc? ( || ( $(python_gen_useflags 'python2*') ) )
ipython? ( || ( $(python_gen_useflags -3) ) )"
RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '>=dev-python/pexpect-2.0[${PYTHON_USEDEP}]' python2_7)
imaging? ( dev-python/pillow[${PYTHON_USEDEP}] )
ipython? ( $(python_gen_cond_dep 'dev-python/ipython[${PYTHON_USEDEP}]' -3) )
latex? (
@@ -33,23 +31,15 @@ RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
)
mathml? (
dev-libs/libxml2:2[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-libs/libxslt[${PYTHON_USEDEP}]' python2_7)
gtk? ( x11-libs/gtkmathview[gtk] )
)
opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
- pyglet? ( $(python_gen_cond_dep 'dev-python/pyglet[${PYTHON_USEDEP}]' python2_7) )
texmacs? ( app-office/texmacs )
- theano? ( $(python_gen_cond_dep 'dev-python/theano[${PYTHON_USEDEP}]' python2_7) )
"
DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] app-text/docbook2X )
test? ( ${RDEPEND} dev-python/pytest[${PYTHON_USEDEP}] )"
-pkg_setup() {
- use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
-}
-
python_prepare_all() {
epatch "${FILESDIR}"/${P}-doc-makefile.patch
epatch "${FILESDIR}"/${P}-zeta.patch
@@ -60,15 +50,6 @@ python_compile() {
PYTHONPATH="." distutils-r1_python_compile
}
-python_compile_all() {
- if use doc; then
- export XDG_CONFIG_HOME="${T}/config-dir"
- mkdir "${XDG_CONFIG_HOME}" || die
- chmod 0700 "${XDG_CONFIG_HOME}" || die
- emake -j1 -C doc html info man cheatsheet
- fi
-}
-
python_test() {
virtx "${PYTHON}" setup.py test
}
@@ -79,12 +60,6 @@ python_install() {
python_install_all() {
local DOCS=( AUTHORS README.rst )
- if use doc; then
- DOCS+=( doc/_build/cheatsheet/cheatsheet.pdf \
- doc/_build/cheatsheet/combinatoric_cheatsheet.pdf )
- local HTML_DOCS=( doc/_build/html/. )
- doinfo doc/_build/texinfo/${PN}.info
- fi
use examples && local EXAMPLES=( examples/. )
distutils-r1_python_install_all
diff --git a/dev-python/sympy/sympy-1.3.ebuild b/dev-python/sympy/sympy-1.3.ebuild
index 966444c34242..078dc48e8f85 100644
--- a/dev-python/sympy/sympy-1.3.ebuild
+++ b/dev-python/sympy/sympy-1.3.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_6,3_7} )
+PYTHON_COMPAT=( python{3_6,3_7} )
inherit distutils-r1 eutils virtualx
@@ -14,10 +14,9 @@ SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples gtk imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs theano"
+IUSE="examples gtk imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs theano"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
- doc? ( || ( $(python_gen_useflags 'python2*') ) )
ipython? ( || ( $(python_gen_useflags -3) ) )"
RESTRICT="test"
@@ -36,7 +35,6 @@ RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
)
mathml? (
dev-libs/libxml2:2[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-libs/libxslt[${PYTHON_USEDEP}]' python2_7)
gtk? ( x11-libs/gtkmathview[gtk] )
)
opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
@@ -47,36 +45,16 @@ RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] app-text/docbook2X )
test? ( ${RDEPEND} dev-python/pytest[${PYTHON_USEDEP}] )"
PATCHES=( "${FILESDIR}"/${P}-eta.patch )
-pkg_setup() {
- use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
-}
-
-python_compile_all() {
- if use doc; then
- export XDG_CONFIG_HOME="${T}/config-dir"
- mkdir "${XDG_CONFIG_HOME}" || die
- chmod 0700 "${XDG_CONFIG_HOME}" || die
- emake -j1 -C doc html info man cheatsheet
- fi
-}
-
python_test() {
virtx "${PYTHON}" setup.py test
}
python_install_all() {
local DOCS=( AUTHORS README.rst )
- if use doc; then
- DOCS+=( doc/_build/cheatsheet/cheatsheet.pdf \
- doc/_build/cheatsheet/combinatoric_cheatsheet.pdf )
- local HTML_DOCS=( doc/_build/html/. )
- doinfo doc/_build/texinfo/${PN}.info
- fi
if use examples; then
dodoc -r examples
docompress -x /usr/share/doc/${PF}/examples
diff --git a/dev-python/sympy/sympy-1.5.1.ebuild b/dev-python/sympy/sympy-1.5.1.ebuild
index 379c5702f687..5ecc82a06a54 100644
--- a/dev-python/sympy/sympy-1.5.1.ebuild
+++ b/dev-python/sympy/sympy-1.5.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{2_7,3_6,3_7} )
+PYTHON_COMPAT=( python{3_6,3_7} )
inherit distutils-r1 eutils virtualx
@@ -14,10 +14,9 @@ SRC_URI="https://github.com/${PN}/${PN}/archive/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples gtk imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs theano"
+IUSE="examples gtk imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs theano"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
- doc? ( || ( $(python_gen_useflags 'python2*') ) )
ipython? ( || ( $(python_gen_useflags -3) ) )"
RESTRICT="test"
@@ -36,7 +35,6 @@ RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
)
mathml? (
dev-libs/libxml2:2[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-libs/libxslt[${PYTHON_USEDEP}]' python2_7)
gtk? ( x11-libs/gtkmathview[gtk] )
)
opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
@@ -47,36 +45,16 @@ RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] app-text/docbook2X )
test? ( ${RDEPEND} dev-python/pytest[${PYTHON_USEDEP}] )"
S="${WORKDIR}/${PN}-${P}"
-pkg_setup() {
- use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
-}
-
-python_compile_all() {
- if use doc; then
- export XDG_CONFIG_HOME="${T}/config-dir"
- mkdir "${XDG_CONFIG_HOME}" || die
- chmod 0700 "${XDG_CONFIG_HOME}" || die
- emake -j1 -C doc html info man cheatsheet
- fi
-}
-
python_test() {
virtx "${PYTHON}" setup.py test
}
python_install_all() {
local DOCS=( AUTHORS README.rst )
- if use doc; then
- DOCS+=( doc/_build/cheatsheet/cheatsheet.pdf \
- doc/_build/cheatsheet/combinatoric_cheatsheet.pdf )
- local HTML_DOCS=( doc/_build/html/. )
- doinfo doc/_build/texinfo/${PN}.info
- fi
if use examples; then
dodoc -r examples
docompress -x /usr/share/doc/${PF}/examples
diff --git a/dev-python/sympy/sympy-1.5.ebuild b/dev-python/sympy/sympy-1.5.ebuild
index 8fadc5ca34ac..c8dda8967474 100644
--- a/dev-python/sympy/sympy-1.5.ebuild
+++ b/dev-python/sympy/sympy-1.5.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_6,3_7} )
+PYTHON_COMPAT=( python{3_6,3_7} )
inherit distutils-r1 eutils virtualx
@@ -14,10 +14,9 @@ SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc examples gtk imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs theano"
+IUSE="examples gtk imaging ipython latex mathml opengl pdf png pyglet symengine test texmacs theano"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
- doc? ( || ( $(python_gen_useflags 'python2*') ) )
ipython? ( || ( $(python_gen_useflags -3) ) )"
RESTRICT="test"
@@ -36,7 +35,6 @@ RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
)
mathml? (
dev-libs/libxml2:2[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-libs/libxslt[${PYTHON_USEDEP}]' python2_7)
gtk? ( x11-libs/gtkmathview[gtk] )
)
opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )
@@ -47,34 +45,14 @@ RDEPEND="dev-python/mpmath[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] app-text/docbook2X )
test? ( ${RDEPEND} dev-python/pytest[${PYTHON_USEDEP}] )"
-pkg_setup() {
- use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
-}
-
-python_compile_all() {
- if use doc; then
- export XDG_CONFIG_HOME="${T}/config-dir"
- mkdir "${XDG_CONFIG_HOME}" || die
- chmod 0700 "${XDG_CONFIG_HOME}" || die
- emake -j1 -C doc html info man cheatsheet
- fi
-}
-
python_test() {
virtx "${PYTHON}" setup.py test
}
python_install_all() {
local DOCS=( AUTHORS README.rst )
- if use doc; then
- DOCS+=( doc/_build/cheatsheet/cheatsheet.pdf \
- doc/_build/cheatsheet/combinatoric_cheatsheet.pdf )
- local HTML_DOCS=( doc/_build/html/. )
- doinfo doc/_build/texinfo/${PN}.info
- fi
if use examples; then
dodoc -r examples
docompress -x /usr/share/doc/${PF}/examples