summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-20 16:37:15 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-20 16:37:15 +0200
commit1da704fcc67bc260070e9c6ac5b6d5117600ef75 (patch)
tree65d9bf27d7e981281a675de07450a8aa80e8f999 /dev-python/stapler
parentdev-python/snaketrace: Enable py3.12 (diff)
downloadgentoo-1da704fcc67bc260070e9c6ac5b6d5117600ef75.tar.gz
gentoo-1da704fcc67bc260070e9c6ac5b6d5117600ef75.tar.bz2
gentoo-1da704fcc67bc260070e9c6ac5b6d5117600ef75.zip
dev-python/stapler: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/stapler')
-rw-r--r--dev-python/stapler/stapler-1.0.0_p20220330-r3.ebuild29
1 files changed, 19 insertions, 10 deletions
diff --git a/dev-python/stapler/stapler-1.0.0_p20220330-r3.ebuild b/dev-python/stapler/stapler-1.0.0_p20220330-r3.ebuild
index 7c84ad2402d5..45767ab87c04 100644
--- a/dev-python/stapler/stapler-1.0.0_p20220330-r3.ebuild
+++ b/dev-python/stapler/stapler-1.0.0_p20220330-r3.ebuild
@@ -3,28 +3,37 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
-COMMIT="382f1edc62296e071093a5419811a2fca9d78d93"
-
+EGIT_COMMIT="382f1edc62296e071093a5419811a2fca9d78d93"
+MY_P="${PN}-${EGIT_COMMIT}"
DESCRIPTION="Suite of tools for PDF files manipulation written in Python"
-HOMEPAGE="https://github.com/hellerbarde/stapler"
-SRC_URI="https://github.com/hellerbarde/${PN}/archive/${COMMIT}.tar.gz -> ${PN}-${COMMIT}.tar.gz"
-S="${WORKDIR}/${PN}-${COMMIT}"
+HOMEPAGE="
+ https://github.com/hellerbarde/stapler/
+ https://pypi.org/project/stapler/
+"
+SRC_URI="
+ https://github.com/hellerbarde/stapler/archive/${EGIT_COMMIT}.tar.gz
+ -> ${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-DEPEND="test? ( dev-python/pypdf[${PYTHON_USEDEP}] )"
-RDEPEND="dev-python/pypdf[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/pypdf[${PYTHON_USEDEP}]
+"
distutils_enable_tests unittest
-PATCHES=( "${FILESDIR}"/${P}-fix-tests-for-PyPDF2-2.x.patch
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-tests-for-PyPDF2-2.x.patch
"${FILESDIR}"/${P}-port-to-PyPDF2-3.0.0.patch
"${FILESDIR}"/${P}-use-poetry-core-backend-for-PEP517.patch
- "${FILESDIR}"/${P}-PyPDF2-to-pypdf.patch )
+ "${FILESDIR}"/${P}-PyPDF2-to-pypdf.patch
+)