summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2018-10-04 13:34:36 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2018-10-04 13:37:55 -0400
commit6129954809d3cb066e8f17d6d6940552f04ae51b (patch)
tree317ba6ab3de1a9042245ef9187b0c644ec94666e /dev-python/sshtunnel/sshtunnel-0.1.4.ebuild
parentsys-apps/nvme-cli: Use uuid USE variable (diff)
downloadgentoo-6129954809d3cb066e8f17d6d6940552f04ae51b.tar.gz
gentoo-6129954809d3cb066e8f17d6d6940552f04ae51b.tar.bz2
gentoo-6129954809d3cb066e8f17d6d6940552f04ae51b.zip
dev-python/sshtunnel: Initial commit
Required by >=dev-db/pgadmin4-3.3 Bug: https://bugs.gentoo.org/665754 Package-Manager: Portage-2.3.40, Repoman-2.3.9 Signed-off-by: Aaron Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-python/sshtunnel/sshtunnel-0.1.4.ebuild')
-rw-r--r--dev-python/sshtunnel/sshtunnel-0.1.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/sshtunnel/sshtunnel-0.1.4.ebuild b/dev-python/sshtunnel/sshtunnel-0.1.4.ebuild
new file mode 100644
index 000000000000..4aeb081ac92f
--- /dev/null
+++ b/dev-python/sshtunnel/sshtunnel-0.1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python SSH tunnels"
+HOMEPAGE="https://pypi.python.org/pypi/sshtunnel"
+SRC_URI="mirror://pypi/s/sshtunnel/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86 ~arm"
+LICENSE="MIT"
+SLOT="0"
+
+IUSE="test"
+
+RDEPEND="dev-python/paramiko[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/tox[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+ esetup.py test
+}