summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-07-15 02:27:05 +0100
committerSam James <sam@gentoo.org>2024-07-15 02:38:26 +0100
commitd01f4d4906c987f050e66c5521f1f25c33f6d613 (patch)
treea6c0d47a983b271f605a3a8f37608143d2f0c620 /dev-python/srt
parentdev-python/pysubs2: new package, add 1.7.2 (diff)
downloadgentoo-d01f4d4906c987f050e66c5521f1f25c33f6d613.tar.gz
gentoo-d01f4d4906c987f050e66c5521f1f25c33f6d613.tar.bz2
gentoo-d01f4d4906c987f050e66c5521f1f25c33f6d613.zip
dev-python/srt: new package, add 3.5.3
New dep of media-video/subliminal. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/srt')
-rw-r--r--dev-python/srt/Manifest1
-rw-r--r--dev-python/srt/metadata.xml17
-rw-r--r--dev-python/srt/srt-3.5.3.ebuild27
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/srt/Manifest b/dev-python/srt/Manifest
new file mode 100644
index 000000000000..44dabb10bc72
--- /dev/null
+++ b/dev-python/srt/Manifest
@@ -0,0 +1 @@
+DIST srt-3.5.3.tar.gz 28296 BLAKE2B 97f8852a799e80401f09219b43b41f5d5f9fe2c7283e2b43312aef70d783d7f1c1bf126e076c3a13c10e74e80ff48f25075cc7a1cef58a99fb4ef32cfa5b2587 SHA512 434331d31763a339ebb7d5b335b9d924b7f6939f307ecd0e5476b91da19b39e0febf1a387199e22f0b15365a4305c24021d85a32a7b65058905abd7946865b70
diff --git a/dev-python/srt/metadata.xml b/dev-python/srt/metadata.xml
new file mode 100644
index 000000000000..a65eb5db742c
--- /dev/null
+++ b/dev-python/srt/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">srt</remote-id>
+ <remote-id type="github">cdown/srt</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/srt/srt-3.5.3.ebuild b/dev-python/srt/srt-3.5.3.ebuild
new file mode 100644
index 000000000000..564075540e07
--- /dev/null
+++ b/dev-python/srt/srt-3.5.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Tiny library for parsing, modifying, and composing SRT files"
+HOMEPAGE="
+ https://github.com/cdown/srt
+ https://pypi.org/project/srt/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="!dev-python/pysrt"
+BDEPEND="
+ test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest