summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-12 09:41:40 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-12 10:40:28 +0100
commite488f334153be73c9f2ad5d325f76ed6ce3d6120 (patch)
tree5847ccf91a3de850f65df67c7d90c81592cd24f1 /dev-python/soupsieve
parentdev-python/sqlalchemy: Bump to 1.4.27 (diff)
downloadgentoo-e488f334153be73c9f2ad5d325f76ed6ce3d6120.tar.gz
gentoo-e488f334153be73c9f2ad5d325f76ed6ce3d6120.tar.bz2
gentoo-e488f334153be73c9f2ad5d325f76ed6ce3d6120.zip
dev-python/soupsieve: Bump to 2.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/soupsieve')
-rw-r--r--dev-python/soupsieve/Manifest1
-rw-r--r--dev-python/soupsieve/soupsieve-2.3.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/soupsieve/Manifest b/dev-python/soupsieve/Manifest
index 0e32f4233843..1d953a1c298b 100644
--- a/dev-python/soupsieve/Manifest
+++ b/dev-python/soupsieve/Manifest
@@ -1,2 +1,3 @@
DIST soupsieve-2.2.1.tar.gz 99298 BLAKE2B 94532421f3b8e49d6ab75a54a60ac861a78eee9f6792ded096e39a8a43d46d195cff9b7d8feab918b0f2debc8a6dd35226ab714384fa7f4d795176e269b6c4cb SHA512 c1339cfca237af7f8915b6d644b8271f769f9a37aa68f8acf536236551baaf9bb44a2f2a736f9168a7649cde14d37b8c24614c9491acbf81e3f4fdaea96b4928
+DIST soupsieve-2.3.1.tar.gz 104251 BLAKE2B c395b8dc0944457d6c5f217a03c6fc5f3895868a629eb72d86733fb0d9c6b1d1c41a2e035d5118c9c6fcc6a22e9ff79b9de8417131d30bbc6e1ba02c813ced56 SHA512 3f1245b27d67e8b37bce4cb0b21b2b3f4d6b7ae112cc66672e5406c0701b28e605ed12db1e111bfeccea15625b17042e398b075b7f026d3f3e15069f0cafccac
DIST soupsieve-2.3.tar.gz 104025 BLAKE2B 37c1cbbb345a24e843a7b1acef5967b914cd93d4fcbe590e9453f9b0b84975e2fbdc601c45e720483370343f40aa643146cab9a53c17be29c6fa76ce026eca78 SHA512 c5d46703aba737c6eea7cc482311fd75dbaaa4929ebf3ed45b580d7e89d1d0be806608adbab974803acd8df5d74435efe1e149bce5cdbd74f77c90bba960859a
diff --git a/dev-python/soupsieve/soupsieve-2.3.1.ebuild b/dev-python/soupsieve/soupsieve-2.3.1.ebuild
new file mode 100644
index 000000000000..9c1e8558c568
--- /dev/null
+++ b/dev-python/soupsieve/soupsieve-2.3.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A modern CSS selector implementation for BeautifulSoup"
+HOMEPAGE="https://github.com/facelessuser/soupsieve/
+ https://pypi.org/project/soupsieve/"
+SRC_URI="https://github.com/facelessuser/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ # Needed for now until something is figured out either at lxml
+ # upstream or libxml2?
+ # See https://github.com/facelessuser/soupsieve/issues/220
+ "${FILESDIR}"/${PN}-2.2.1-lxml-libxml2-tests.patch
+)
+
+distutils_enable_tests pytest