summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-17 09:04:13 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-17 09:36:48 +0200
commitc4469cac37054779c2d9b29f9a92ab68e0fe9aa8 (patch)
treef02bfc677d9ff13d6bcd07290c718ecb482b53e9 /dev-python/sortedcontainers
parentdev-python/aiofiles: Bump to 0.7.0 (diff)
downloadgentoo-c4469cac37054779c2d9b29f9a92ab68e0fe9aa8.tar.gz
gentoo-c4469cac37054779c2d9b29f9a92ab68e0fe9aa8.tar.bz2
gentoo-c4469cac37054779c2d9b29f9a92ab68e0fe9aa8.zip
dev-python/sortedcontainers: Bump to 2.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/sortedcontainers')
-rw-r--r--dev-python/sortedcontainers/Manifest1
-rw-r--r--dev-python/sortedcontainers/sortedcontainers-2.4.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/sortedcontainers/Manifest b/dev-python/sortedcontainers/Manifest
index 5de1ab09278b..9c855ff5be0a 100644
--- a/dev-python/sortedcontainers/Manifest
+++ b/dev-python/sortedcontainers/Manifest
@@ -1 +1,2 @@
DIST python-sortedcontainers-2.3.0.gh.tar.gz 9228968 BLAKE2B cdff8230d4e4ac42a89ed3192666ebf22cd48a4475f1dc173cffb0339c7f27e9cdfde1fb631daadf04adf2c00bed8a924e1202712d0ebcbd591f5542de863461 SHA512 0488e2f9f07ea7e4737ade69441f02614b63cfccb32a71af4e5953001bfa840d2e113a36a0a0a6d4c1e7fdd920ac3937b0baaea522d742547a4d81a99b8d1a6c
+DIST python-sortedcontainers-2.4.0.gh.tar.gz 9229380 BLAKE2B ca9348ab7d467b2a81126217451262bb0547901b953edc3bba7c87c67b415eef5c3d454a08d227ebc8b213c1cc7db6262e864511fe67beefe865014ae5fc5977 SHA512 f80185c6f95a85cc78f88f6f6cf389eb48be22cf94d5fcd84f3592873f17de37ec7f44c1627b7f02956ac4b4f74ca4febefc47d3c6232f70ee05dbb2449ad770
diff --git a/dev-python/sortedcontainers/sortedcontainers-2.4.0.ebuild b/dev-python/sortedcontainers/sortedcontainers-2.4.0.ebuild
new file mode 100644
index 000000000000..af2cd3f803bd
--- /dev/null
+++ b/dev-python/sortedcontainers/sortedcontainers-2.4.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Python library to sort collections and containers"
+HOMEPAGE="http://www.grantjenks.com/docs/sortedcontainers/
+ https://pypi.org/project/sortedcontainers/
+ https://github.com/grantjenks/python-sortedcontainers/"
+SRC_URI="
+ https://github.com/grantjenks/python-sortedcontainers/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTHONPATH=.
+ epytest --ignore docs/conf.py
+}