summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-24 17:07:20 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-24 17:07:20 +0200
commit57f917e729e451584cb18b72e650234f1d096c53 (patch)
treebd96a55544978b62247103542285c71d4e49d478 /dev-python/socketpool
parentdev-python/pycurl: Remove old (diff)
downloadgentoo-57f917e729e451584cb18b72e650234f1d096c53.tar.gz
gentoo-57f917e729e451584cb18b72e650234f1d096c53.tar.bz2
gentoo-57f917e729e451584cb18b72e650234f1d096c53.zip
dev-python/socketpool: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/socketpool')
-rw-r--r--dev-python/socketpool/socketpool-0.5.3-r2.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/dev-python/socketpool/socketpool-0.5.3-r2.ebuild b/dev-python/socketpool/socketpool-0.5.3-r2.ebuild
deleted file mode 100644
index 4d743c76a089..000000000000
--- a/dev-python/socketpool/socketpool-0.5.3-r2.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A simple Python socket pool"
-HOMEPAGE="https://github.com/benoitc/socketpool/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ppc ppc64 s390 ~sparc x86"
-IUSE="examples gevent"
-LICENSE="|| ( MIT public-domain )"
-SLOT="0"
-
-RDEPEND="
- gevent? (
- $(python_gen_cond_dep '
- dev-python/gevent[${PYTHON_USEDEP}]
- ' 'python*')
- )"
-
-BDEPEND="
- test? (
- !ia64? (
- $(python_gen_cond_dep '
- dev-python/gevent[${PYTHON_USEDEP}]
- ' 'python*')
- )
- )"
-
-PATCHES=( "${FILESDIR}"/${PN}-0.5.2-locale.patch )
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # py3.9
- sed -i -e 's:isAlive:is_alive:' socketpool/backend_thread.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- cp -r examples tests "${BUILD_DIR}" || die
-
- pushd "${BUILD_DIR}" >/dev/null || die
- pytest -vv tests || die "Tests fail with ${EPYTHON}"
- popd >/dev/null || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- use examples && dodoc -r examples
-
- # package installs unneeded LICENSE files here
- rm -r "${ED}"/usr/socketpool || die
-}