summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-17 18:35:35 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-17 19:03:10 +0200
commit1db2e2f6b9f58d5789cfed591aeb1a0fd19480a5 (patch)
tree34cd8d464ef69ddc678e3a8d83d83a42363d7f52 /dev-python/simsimd
parentdev-python/simsimd: Remove old (diff)
downloadgentoo-1db2e2f6b9f58d5789cfed591aeb1a0fd19480a5.tar.gz
gentoo-1db2e2f6b9f58d5789cfed591aeb1a0fd19480a5.tar.bz2
gentoo-1db2e2f6b9f58d5789cfed591aeb1a0fd19480a5.zip
dev-python/simsimd: Bump to 5.7.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/simsimd')
-rw-r--r--dev-python/simsimd/Manifest1
-rw-r--r--dev-python/simsimd/simsimd-5.7.3.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/simsimd/Manifest b/dev-python/simsimd/Manifest
index 7907dafcfc65..07fc2b0a3910 100644
--- a/dev-python/simsimd/Manifest
+++ b/dev-python/simsimd/Manifest
@@ -1,2 +1,3 @@
DIST SimSIMD-5.6.4.gh.tar.gz 164134 BLAKE2B 65f0aa8ef132ef9a05a3cac03e6773adfbca1b5860952563ca6e7f7ce322d71d3de137705f9c1fbd1cc53a23feade46fcb1f100e6489e03a1ff51ea5b571c5e9 SHA512 f20cd5bb3011e87ceed7f7a6b82b9805fa1b3fb2dc8aadda145d37580573f50bae44442202b5af19a5372e77ac5499ea0015f2e00011a1e8d0272ba991d46606
DIST SimSIMD-5.7.2.gh.tar.gz 180385 BLAKE2B ac2a05d45244fbc55da67e1cefffc042d58da192c9c5935a5a236cb8907b6f26414c873515c687e25f3dd6c41ea166ed2771ad0036a32f0f6d2a1d7419e4df53 SHA512 dd3dcf29e136facf98ebec197a00fcfb720f5d9372bd3576a5a9203221f04ad08d5076c57c79ccc3fe238c31f6159ef5b43e16e676cb785b6ad93451a1518607
+DIST SimSIMD-5.7.3.gh.tar.gz 181144 BLAKE2B e00704d3a33c3bec6422f2c0a4e7c2d11c124cf8be898334317f5a4cf73b6ed5143b6c07efb9fb167ec786e0da0812072d141fc778642df21e93d18404238fa2 SHA512 ab78d4415ed0f2964470ccd36d3d737a2715b1a5a4222613d2f0f4be6a516da0e339329cbd421c6b7f6a1bc701da6ec2f3937cba5a8ea1f632beea8000d90c8f
diff --git a/dev-python/simsimd/simsimd-5.7.3.ebuild b/dev-python/simsimd/simsimd-5.7.3.ebuild
new file mode 100644
index 000000000000..3b7152ad7a71
--- /dev/null
+++ b/dev-python/simsimd/simsimd-5.7.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 toolchain-funcs
+
+MY_P=SimSIMD-${PV}
+DESCRIPTION="Fastest SIMD-Accelerated Vector Similarity Functions for x86 and Arm"
+HOMEPAGE="
+ https://github.com/ashvardanian/SimSIMD/
+ https://pypi.org/project/simsimd/
+"
+# no sdist, as of 4.3.1
+# https://github.com/ashvardanian/SimSIMD/issues/113
+SRC_URI="
+ https://github.com/ashvardanian/SimSIMD/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="openmp"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-repeat[${PYTHON_USEDEP}]
+ dev-python/tabulate[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
+ tc-check-openmp
+ fi
+}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
+ tc-check-openmp
+ fi
+}
+
+src_prepare() {
+ sed -i -e '/-O3/d' setup.py || die
+ if ! use openmp; then
+ sed -i -e '/-fopenmp/d' setup.py || die
+ fi
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p repeat scripts/test.py
+}