summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-01-16 00:18:55 -0500
committerSam James <sam@gentoo.org>2024-01-16 05:47:45 +0000
commit8c8e5446966b720e8c28d153932d801764dab28a (patch)
treea747cbc81414472225513d82f330ba702a0ba1b4 /dev-python/scipy
parentdev-libs/libatomic_ops: apply elibtoolize for LTO fixes (diff)
downloadgentoo-8c8e5446966b720e8c28d153932d801764dab28a.tar.gz
gentoo-8c8e5446966b720e8c28d153932d801764dab28a.tar.bz2
gentoo-8c8e5446966b720e8c28d153932d801764dab28a.zip
dev-python/scipy: filter LTO since it is unsafe
The underlying issue is really just a lot of old fortran code. Not all compiled modules are actually LTO-unsafe. But handling this granularly requires good cooperation with the build system. I handled this upstream via https://github.com/scipy/scipy/pull/19857. While we wait for scipy 1.13.0 to be released, prevent older scipy versions from using LTO. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/scipy')
-rw-r--r--dev-python/scipy/scipy-1.11.3-r1.ebuild5
-rw-r--r--dev-python/scipy/scipy-1.11.4.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-python/scipy/scipy-1.11.3-r1.ebuild b/dev-python/scipy/scipy-1.11.3-r1.ebuild
index 9f68cd59364e..53cfef682124 100644
--- a/dev-python/scipy/scipy-1.11.3-r1.ebuild
+++ b/dev-python/scipy/scipy-1.11.3-r1.ebuild
@@ -9,7 +9,7 @@ DISTUTILS_USE_PEP517=meson-python
PYTHON_COMPAT=( pypy3 python3_{10..12} )
PYTHON_REQ_USE="threads(+)"
-inherit fortran-2 distutils-r1 multiprocessing
+inherit flag-o-matic fortran-2 distutils-r1 multiprocessing
DESCRIPTION="Scientific algorithms library for Python"
HOMEPAGE="
@@ -87,6 +87,9 @@ src_unpack() {
}
python_configure_all() {
+ # https://github.com/scipy/scipy/pull/19857
+ # Fixed in 1.13.0
+ filter-lto
DISTUTILS_ARGS=(
-Dblas=blas
-Dlapack=lapack
diff --git a/dev-python/scipy/scipy-1.11.4.ebuild b/dev-python/scipy/scipy-1.11.4.ebuild
index eb69b66541e5..9d60b95cd5e7 100644
--- a/dev-python/scipy/scipy-1.11.4.ebuild
+++ b/dev-python/scipy/scipy-1.11.4.ebuild
@@ -9,7 +9,7 @@ DISTUTILS_USE_PEP517=meson-python
PYTHON_COMPAT=( pypy3 python3_{10..12} )
PYTHON_REQ_USE="threads(+)"
-inherit fortran-2 distutils-r1 multiprocessing
+inherit flag-o-matic fortran-2 distutils-r1 multiprocessing
DESCRIPTION="Scientific algorithms library for Python"
HOMEPAGE="
@@ -87,6 +87,9 @@ src_unpack() {
}
python_configure_all() {
+ # https://github.com/scipy/scipy/pull/19857
+ # Fixed in 1.13.0
+ filter-lto
DISTUTILS_ARGS=(
-Dblas=blas
-Dlapack=lapack