summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-08 10:06:04 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-08 10:56:39 +0200
commitd748eac6942e6e37b5ea4fdfe29bcb49e9a2b9ce (patch)
treee57ff5fd9633452b2725fdb637459b28465feabd /dev-python/rope/rope-1.0.0.ebuild
parentdev-python/trimesh: Bump to 3.10.8 (diff)
downloadgentoo-d748eac6942e6e37b5ea4fdfe29bcb49e9a2b9ce.tar.gz
gentoo-d748eac6942e6e37b5ea4fdfe29bcb49e9a2b9ce.tar.bz2
gentoo-d748eac6942e6e37b5ea4fdfe29bcb49e9a2b9ce.zip
dev-python/rope: Bump to 1.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/rope/rope-1.0.0.ebuild')
-rw-r--r--dev-python/rope/rope-1.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/rope/rope-1.0.0.ebuild b/dev-python/rope/rope-1.0.0.ebuild
new file mode 100644
index 000000000000..a59e2a961a63
--- /dev/null
+++ b/dev-python/rope/rope-1.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python refactoring library"
+HOMEPAGE="
+ https://pypi.org/project/rope/
+ https://github.com/python-rope/rope/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest