summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-01-02 20:53:55 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-01-02 20:53:55 +0200
commit68f6ce3f4004126cfc423ef8780a444865ba129e (patch)
tree06afad92d0a42903fcb225ab5ad01cd091e0f986 /dev-python/rich
parentapp-emulation/qemu: REQ_USE+="static? ( !pam )" (diff)
downloadgentoo-68f6ce3f4004126cfc423ef8780a444865ba129e.tar.gz
gentoo-68f6ce3f4004126cfc423ef8780a444865ba129e.tar.bz2
gentoo-68f6ce3f4004126cfc423ef8780a444865ba129e.zip
dev-python/rich: add 10.16.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/rich')
-rw-r--r--dev-python/rich/Manifest1
-rw-r--r--dev-python/rich/rich-10.16.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index 9bcbe1a2a8e8..05d8ab2361e1 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -6,3 +6,4 @@ DIST rich-10.15.1.tar.gz 16279572 BLAKE2B e91a9d168d88c1d8db4b0901809c4da29d32b2
DIST rich-10.15.2.tar.gz 16282858 BLAKE2B 7fe05eb357e5137319764b0d751c3bc68f8545e391575a9a360b252c395714ecb8ad7b944e7c77e74990413cb6bfb2a6c6db0fb8e72eb098f91c8d5d86bc9f8a SHA512 02e851cc9a72cb62d1826f82a5b8919a8911cf3dbdfe5f5443a89b2b7bc48c575dcf5ba63c17da60cf2ef9de3d036c7b68a845610be72af63d082d487c3b61c2
DIST rich-10.16.0.tar.gz 16280103 BLAKE2B af66398a4bc6e3e5503418721906679dc6f964b6dcbb56195f64d0ef4f504d9e0002f8b727c4fba7b42dda8790a03bb12a85150b99d5294712e38dea2800f841 SHA512 48c9e4d0b733cf79e9bceac284ca3cf37c14f52c0f3590f08acd9b0ea791da0200753f3cbae13a619b9c42fdb1167d55724c80123e2935bf2ed7133a15639ac8
DIST rich-10.16.1.tar.gz 16280385 BLAKE2B dda2e6a64f9ecfe99fdda3a2e24c6a859e25eca48ebc2af63dbea3c8b90f977e10253721e85b876165c9f51c52ceed057e77b08cf2c77c28de67b8a2c49c4617 SHA512 341aa3fdb7fe608d15c867eb50f36fcc250e041a256e4bee86f0c69e7e0f9239c84be88833dad56f05edeb09a734d64f423b9080bd13b88c3a59d958e8ff1f4c
+DIST rich-10.16.2.tar.gz 16282443 BLAKE2B ccc7292e265770880539d6a1a6b2e819b45e2e3d4d152f1a16c56f2da74c9a472ae49ea0a4a677ad71c4dd087fade2c415484073b4b2cd86869ad7c43c32b162 SHA512 9cb8b0c8105589db22d7efdc47cbfa20531cd184f07855db4bfafb667299c7d3e520b19e3b33e7818affb7a5674805849ee9f2e770927e285ccd7f4f838982c3
diff --git a/dev-python/rich/rich-10.16.2.ebuild b/dev-python/rich/rich-10.16.2.ebuild
new file mode 100644
index 000000000000..23da7333ab91
--- /dev/null
+++ b/dev-python/rich/rich-10.16.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for renrering rich text, tables, etc. to the terminal"
+HOMEPAGE="https://github.com/willmcgugan/rich"
+SRC_URI="https://github.com/willmcgugan/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # check for exact color render string, which changes across pygments bumps
+ tests/test_syntax.py::test_python_render
+ tests/test_syntax.py::test_python_render_simple
+ tests/test_syntax.py::test_python_render_indent_guides
+ )
+ epytest -p no:pytest-qt
+}
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}