summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-15 22:38:22 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-15 22:38:22 -0600
commitcb1ea1455532aa7ba09a6ed64584e3bb6cb75232 (patch)
tree8ca47a67fca9c5946e6892e40448bbf36b69cd18 /dev-python/requestsexceptions
parentdev-python/mox3: 0.24.0 bup (diff)
downloadgentoo-cb1ea1455532aa7ba09a6ed64584e3bb6cb75232.tar.gz
gentoo-cb1ea1455532aa7ba09a6ed64584e3bb6cb75232.tar.bz2
gentoo-cb1ea1455532aa7ba09a6ed64584e3bb6cb75232.zip
dev-python/requestsexceptions: 1.4.0 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/requestsexceptions')
-rw-r--r--dev-python/requestsexceptions/Manifest1
-rw-r--r--dev-python/requestsexceptions/requestsexceptions-1.4.0.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/requestsexceptions/Manifest b/dev-python/requestsexceptions/Manifest
index c214b74bdc4f..df7186700c16 100644
--- a/dev-python/requestsexceptions/Manifest
+++ b/dev-python/requestsexceptions/Manifest
@@ -1 +1,2 @@
DIST requestsexceptions-1.1.3.tar.gz 6606 BLAKE2B 7dbbdc095ba1ec20b41a3c7a0dcef5f10fbcd8d9f6bfc9082bde09a23a9d75f1be96f79b74551691d038b758a7d7bd1568842be9fd139a4c4d3279e63376db9d SHA512 33a848b04db500b3481b7df2553e244e1967e5124de1606f73fb38f0b2681253ca2bd921386ce50f1144a8dc8d6f8e07be058a3d9f13c7831f77cade0a42fd38
+DIST requestsexceptions-1.4.0.tar.gz 6880 BLAKE2B 7539cb7993de817a9d22db3f2e1121b65850cc80723c149243e6e540df7f1229abf66a5a443ca41eb855510caa3f10ca6829d89ad39745fe8180359a92037cff SHA512 f631fa650a969ccc74eebfe7522b16e969de4bf48b6f7140eba46a301cfc5a56b9a8354785990daabae025a8175f6b62bf0870d73468d96ba92fa09f4ef3c566
diff --git a/dev-python/requestsexceptions/requestsexceptions-1.4.0.ebuild b/dev-python/requestsexceptions/requestsexceptions-1.4.0.ebuild
new file mode 100644
index 000000000000..8161b92f7bcb
--- /dev/null
+++ b/dev-python/requestsexceptions/requestsexceptions-1.4.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Finds the correct path to exceptions in the requests library."
+HOMEPAGE="https://github.com/openstack-infra/requestsexceptions"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}"