summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-26 06:12:52 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-26 06:39:13 +0100
commit419d42ab582e4aad13f59373bf432aa5eb130499 (patch)
treeba7971a5d304df7c4e48db8158f3d881befd32a2 /dev-python/python-utils
parentdev-libs/c-blosc2: Bump to 2.13.1 (diff)
downloadgentoo-419d42ab582e4aad13f59373bf432aa5eb130499.tar.gz
gentoo-419d42ab582e4aad13f59373bf432aa5eb130499.tar.bz2
gentoo-419d42ab582e4aad13f59373bf432aa5eb130499.zip
dev-python/python-utils: Bump to 3.8.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-utils')
-rw-r--r--dev-python/python-utils/Manifest1
-rw-r--r--dev-python/python-utils/python-utils-3.8.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/python-utils/Manifest b/dev-python/python-utils/Manifest
index 363313da9b47..efcde5404fdf 100644
--- a/dev-python/python-utils/Manifest
+++ b/dev-python/python-utils/Manifest
@@ -1 +1,2 @@
DIST python-utils-3.8.1.tar.gz 30545 BLAKE2B 9132387de0d12c51dbd4a7a3eda561fa9935c9fa86d76346e50e4ee9401065211a02bb45e89df402900263d28b115b761c2a8d7a2fe799866da20d4848f48451 SHA512 ccba9651cc99a8f4e3f13e7ff66a43a40d2e85bc735b6246524269495ff321225a0dcad9abd03ca9cb61b4b1b35a27009fac3fe87e3f748ffc5c87a956acd335
+DIST python-utils-3.8.2.tar.gz 30431 BLAKE2B 3c53c02729f601b30e68a26cd4b61e49c29f036a1327c43124e326dae173d1b528035bb0952c349ec43f3cd6e159c2e0d5e82c8c46efd12c95f445dbb20751c0 SHA512 e0de794abe95f3e205fcbde0fd52615f44128ffb702a406ff0d3f7ce2640ff60ac3cc508829245bce750ed191c9d3ae563b8f0619af4c2c43cacde6a1aa0fde4
diff --git a/dev-python/python-utils/python-utils-3.8.2.ebuild b/dev-python/python-utils/python-utils-3.8.2.ebuild
new file mode 100644
index 000000000000..8bb0898ed28b
--- /dev/null
+++ b/dev-python/python-utils/python-utils-3.8.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Collection of small Python functions & classes"
+HOMEPAGE="
+ https://github.com/WoLpH/python-utils/
+ https://pypi.org/project/python-utils/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ docs
+ _python_utils_tests/test_logger.py
+ python_utils/loguru.py
+)
+
+EPYTEST_DESELECT=(
+ # fragile
+ _python_utils_tests/test_time.py::test_timeout_generator
+)
+
+python_prepare_all() {
+ sed -i -e '/--cov/d' -e '/--mypy/d' pytest.ini || die
+ distutils-r1_python_prepare_all
+}