summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-30 10:55:25 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-30 11:04:22 +0100
commite5873eeb500bdf7e4f87e105574b42608948719a (patch)
tree963b5a6bdc06feb8a34122cfb7e4434d396edaa0 /dev-python/python-systemd
parentpackage.mask: Last rite dev-python/python-slip (diff)
downloadgentoo-e5873eeb500bdf7e4f87e105574b42608948719a.tar.gz
gentoo-e5873eeb500bdf7e4f87e105574b42608948719a.tar.bz2
gentoo-e5873eeb500bdf7e4f87e105574b42608948719a.zip
dev-python/python-systemd: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-systemd')
-rw-r--r--dev-python/python-systemd/python-systemd-234-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/python-systemd/python-systemd-234-r2.ebuild b/dev-python/python-systemd/python-systemd-234-r2.ebuild
new file mode 100644
index 000000000000..60d75ffb0ea8
--- /dev/null
+++ b/dev-python/python-systemd/python-systemd-234-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2015-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for native access to the systemd facilities"
+HOMEPAGE="https://github.com/systemd/python-systemd"
+SRC_URI="https://github.com/systemd/python-systemd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="sys-apps/systemd:0="
+RDEPEND="${DEPEND}
+ !sys-apps/systemd[python(-)]
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-py3.10.patch
+)
+
+distutils_enable_tests pytest
+
+python_compile() {
+ # https://bugs.gentoo.org/690316
+ distutils-r1_python_compile -j1
+}
+
+src_test() {
+ # prevent relative import
+ rm -r systemd || die
+ distutils-r1_src_test
+}
+
+python_test() {
+ unset NOTIFY_SOCKET
+ epytest --pyargs systemd -o cache_dir="${T}"
+}