summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-20 18:10:43 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-20 18:40:41 +0200
commit925e31c2dec4918105e46a63be2048918498b164 (patch)
tree416469e5279aa55795683ba6a7195de6a72a148a /dev-python/python-stdnum
parentdev-python/mkdocstrings-python: Bump to 1.5.0 (diff)
downloadgentoo-925e31c2dec4918105e46a63be2048918498b164.tar.gz
gentoo-925e31c2dec4918105e46a63be2048918498b164.tar.bz2
gentoo-925e31c2dec4918105e46a63be2048918498b164.zip
dev-python/python-stdnum: Bump to 1.19
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-stdnum')
-rw-r--r--dev-python/python-stdnum/Manifest1
-rw-r--r--dev-python/python-stdnum/python-stdnum-1.19.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/python-stdnum/Manifest b/dev-python/python-stdnum/Manifest
index 7ed21d6899d9..773e0a32e16d 100644
--- a/dev-python/python-stdnum/Manifest
+++ b/dev-python/python-stdnum/Manifest
@@ -1 +1,2 @@
DIST python-stdnum-1.18.tar.gz 1138676 BLAKE2B 724afd5d015090023582bc078f278d4107a12d4f126a61eb026b69040654d0890dc0eb0aa197565e844c34f0426f7f0072dac2b8191ba3a15bc87ae7c0b73536 SHA512 ca211fa3f7a0c0a913c5b0c6e32cb477025e203eb4c0a648e47bf95cb361d800d620dc4ebcb3007eefbb5595098486963ffee71ea2c37f84d86443d01131db7c
+DIST python-stdnum-1.19.tar.gz 1134517 BLAKE2B a6e35abcd00302dff0c6df82c13691c4528de069b7702f905aabffd840b7d95902f2c74525d824606bc4b28579d38153367997a73910ab93afb4eb4272b76c40 SHA512 02c56aea710a9a02e14160840fbd45751cd00f1a49b1d046124945ba92e2dd3377006f44a146030522d09b92f809ceb4d1e3589ef3d9c9302f7674a79602ef07
diff --git a/dev-python/python-stdnum/python-stdnum-1.19.ebuild b/dev-python/python-stdnum/python-stdnum-1.19.ebuild
new file mode 100644
index 000000000000..2bdc447fc8ce
--- /dev/null
+++ b/dev-python/python-stdnum/python-stdnum-1.19.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+PYPI_NO_NORMALIZE=1
+inherit distutils-r1 pypi
+
+DESCRIPTION="A module to handle standardized numbers and codes"
+HOMEPAGE="
+ https://arthurdejong.org/python-stdnum/
+ https://github.com/arthurdejong/python-stdnum/
+ https://pypi.org/project/python-stdnum/
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vies"
+
+RDEPEND="
+ vies? (
+ || (
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/suds-community[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov.*::' setup.cfg || die
+ distutils-r1_src_prepare
+}