summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-21 17:40:29 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-21 17:51:33 +0200
commitb8771b47e7246df3d545088c35adb9dd88b99138 (patch)
tree14b9f5494c4644e9a9c9a9a5cbde2672960086cb /dev-python/python-socks
parentdev-python/voluptuous: Mark ALLARCHES (diff)
downloadgentoo-b8771b47e7246df3d545088c35adb9dd88b99138.tar.gz
gentoo-b8771b47e7246df3d545088c35adb9dd88b99138.tar.bz2
gentoo-b8771b47e7246df3d545088c35adb9dd88b99138.zip
dev-python/python-socks: New package, dep of aiohttp-socks
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-socks')
-rw-r--r--dev-python/python-socks/Manifest1
-rw-r--r--dev-python/python-socks/metadata.xml7
-rw-r--r--dev-python/python-socks/python-socks-1.1.0.ebuild32
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/python-socks/Manifest b/dev-python/python-socks/Manifest
new file mode 100644
index 000000000000..1751c8394142
--- /dev/null
+++ b/dev-python/python-socks/Manifest
@@ -0,0 +1 @@
+DIST python-socks-1.1.0.gh.tar.gz 1358296 BLAKE2B c599095a7f687ba1bba6f0ddbbc8ef2e680cb6be4e5d2250fad88c3a3273fb2044712045b20c5a358ed9dcbaef07e5133b6d672698d8caf4b978c9e633a5df70 SHA512 e38594815e5f943f810862dfe5d07a802601e41e879f68b4fa70c8087be0387a91e99e1b0578f2819557832b5e53be9773043a9617c72017c41e9377c4f35ef1
diff --git a/dev-python/python-socks/metadata.xml b/dev-python/python-socks/metadata.xml
new file mode 100644
index 000000000000..266e3f19ca59
--- /dev/null
+++ b/dev-python/python-socks/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/python-socks/python-socks-1.1.0.ebuild b/dev-python/python-socks/python-socks-1.1.0.ebuild
new file mode 100644
index 000000000000..8efe7d9b3616
--- /dev/null
+++ b/dev-python/python-socks/python-socks-1.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="SOCKS4, SOCKS5, HTTP tunneling functionality for Python"
+HOMEPAGE="
+ https://pypi.org/project/python-socks/
+ https://github.com/romis2012/python-socks/"
+SRC_URI="
+ https://github.com/romis2012/python-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# tests rely on connecting to Internet
+RESTRICT="test"
+
+# trio, curio are not packaged
+# asyncio is the only backend we have, so dep on its deps unconditionally
+RDEPEND="dev-python/async_timeout[${PYTHON_USEDEP}]"
+#BDEPEND="
+# test? (
+# dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+# dev-python/yarl[${PYTHON_USEDEP}]
+# )"
+
+#distutils_enable_tests pytest