summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/python-mpd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/python-mpd')
-rw-r--r--dev-python/python-mpd/Manifest2
-rw-r--r--dev-python/python-mpd/metadata.xml13
-rw-r--r--dev-python/python-mpd/python-mpd-0.5.3.ebuild26
-rw-r--r--dev-python/python-mpd/python-mpd-0.5.4.ebuild26
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/python-mpd/Manifest b/dev-python/python-mpd/Manifest
new file mode 100644
index 000000000000..835b81c54ef6
--- /dev/null
+++ b/dev-python/python-mpd/Manifest
@@ -0,0 +1,2 @@
+DIST python-mpd-0.5.3.tar.gz 40504 SHA256 2809edf6549596609cd11243d2d847e5981d6e7142a6d5639327a56c72541c94 SHA512 9a3ec0787800e08a34c3d888821f3fab5c9e7e90d5afa382afa5ddfe98cb42fbdcadaa4dc5a2df951dbd42aacd7081a2542847509b7350de232ade3e05fbd638 WHIRLPOOL d434170a44e80180048e13c3486f37eb6e7f98164378b1134cfd30713c0a8cbf201b6cad978dbcc7b3de408c1652ae3adb8b4fd5b4b74c2226b1d63afd92bad9
+DIST python-mpd-0.5.4.tar.gz 45542 SHA256 04dbc3b8d90746298e42852c5b7fb5be5e7af2ca03e812059639b6c060d98c53 SHA512 6303d0eb1ef8120777b2c6a020e30bcc70bbe969b63790391c79ff0baf22c5050fce6a6e4cb80a86351cd76c93c92efb06b4fc2dd2087955d979210c511940ee WHIRLPOOL 4044cb6c368a8e7796775fcca6fb5f1b7df3faf8042b40e6d9baa2129dc6c2a2e500aa523a9ecfed28b561532090939cc87e82a0451085cd73b369c714c83f18
diff --git a/dev-python/python-mpd/metadata.xml b/dev-python/python-mpd/metadata.xml
new file mode 100644
index 000000000000..b0b8e66ea5c5
--- /dev/null
+++ b/dev-python/python-mpd/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>angelos@gentoo.org</email>
+ <name>Christoph Mende</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">python-mpd</remote-id>
+ <remote-id type="github">Mic92/python-mpd2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-mpd/python-mpd-0.5.3.ebuild b/dev-python/python-mpd/python-mpd-0.5.3.ebuild
new file mode 100644
index 000000000000..3130e1db9d4f
--- /dev/null
+++ b/dev-python/python-mpd/python-mpd-0.5.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python MPD client library"
+HOMEPAGE="https://github.com/Mic92/python-mpd2"
+SRC_URI="https://github.com/Mic92/${PN}2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+SLOT="0"
+IUSE="test"
+
+DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( doc/changes.rst doc/topics/{advanced,commands,getting-started,logging}.rst README.rst )
+
+python_test() {
+ "${PYTHON}" test.py || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/python-mpd/python-mpd-0.5.4.ebuild b/dev-python/python-mpd/python-mpd-0.5.4.ebuild
new file mode 100644
index 000000000000..f546b3c7ecb1
--- /dev/null
+++ b/dev-python/python-mpd/python-mpd-0.5.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python MPD client library"
+HOMEPAGE="https://github.com/Mic92/python-mpd2"
+SRC_URI="https://github.com/Mic92/${PN}2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE="test"
+
+DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( doc/changes.rst doc/topics/{advanced,commands,getting-started,logging}.rst README.rst )
+
+python_test() {
+ "${PYTHON}" test.py || die "Tests fail with ${EPYTHON}"
+}