summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-03-02 22:15:52 -0800
committerMatt Turner <mattst88@gentoo.org>2020-03-02 22:17:04 -0800
commitd59faf751cc6da052f20b2b6edeb1330a303aac4 (patch)
tree65f4922d3e9b055eded8316fd99659ca6c704ca9 /dev-python/python-magic
parentapp-text/dblatex: Drop old 0.3.7 stable (diff)
downloadgentoo-d59faf751cc6da052f20b2b6edeb1330a303aac4.tar.gz
gentoo-d59faf751cc6da052f20b2b6edeb1330a303aac4.tar.bz2
gentoo-d59faf751cc6da052f20b2b6edeb1330a303aac4.zip
dev-python/python-magic: Add patch to fix tests
Closes: https://bugs.gentoo.org/663610 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/python-magic')
-rw-r--r--dev-python/python-magic/files/python-magic-0.4.15-fix-gzip-test-2.patch26
-rw-r--r--dev-python/python-magic/python-magic-0.4.15-r1.ebuild2
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/python-magic/files/python-magic-0.4.15-fix-gzip-test-2.patch b/dev-python/python-magic/files/python-magic-0.4.15-fix-gzip-test-2.patch
new file mode 100644
index 000000000000..4dd362ebb610
--- /dev/null
+++ b/dev-python/python-magic/files/python-magic-0.4.15-fix-gzip-test-2.patch
@@ -0,0 +1,26 @@
+From 18c909c4c98463d8292a7d1733aec007f178f1e5 Mon Sep 17 00:00:00 2001
+From: Adam Hupp <adam@hupp.org>
+Date: Sat, 11 Jan 2020 21:57:24 -0800
+Subject: [PATCH] Hopefully fix #105
+
+---
+ test/test.py | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/test/test.py b/test/test.py
+index 62e8a03..c15227d 100755
+--- a/test/test.py
++++ b/test/test.py
+@@ -78,7 +78,11 @@ def test_descriptions(self):
+ 'gzip compressed data, was "test", last modified'
+ ': Sun Jun 29 01:32:52 2008, from Unix',
+ 'gzip compressed data, was "test", last modified'
+- ': Sun Jun 29 01:32:52 2008, from Unix, original size 15'),
++ ': Sun Jun 29 01:32:52 2008, from Unix, original size 15',
++ 'gzip compressed data, was "test", '
++ 'last modified: Sun Jun 29 01:32:52 2008, '
++ 'from Unix, original size modulo 2^32 15'
++ ),
+ 'text.txt': 'ASCII text',
+ }, buf_equals_file=False)
+ finally:
diff --git a/dev-python/python-magic/python-magic-0.4.15-r1.ebuild b/dev-python/python-magic/python-magic-0.4.15-r1.ebuild
index 8f25dcdad7e6..e17297d18138 100644
--- a/dev-python/python-magic/python-magic-0.4.15-r1.ebuild
+++ b/dev-python/python-magic/python-magic-0.4.15-r1.ebuild
@@ -31,6 +31,8 @@ PATCHES=(
"${FILESDIR}/${P}-fix-gzip-test.patch"
# https://github.com/ahupp/python-magic/commit/4bda684f8b461cc1f69593799efcf6afe8397756
"${FILESDIR}/${P}-fix-jpeg-test.patch"
+ # https://github.com/ahupp/python-magic/commit/18c909c4c98463d8292a7d1733aec007f178f1e5
+ "${FILESDIR}/${P}-fix-gzip-test-2.patch"
)
python_test() {