summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-02-03 22:00:06 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-02-03 22:39:24 +0200
commit36ee368becbb62e37e9a548e88e6e9390816c650 (patch)
treed91152ef9666d7b3206982a85f901571f49540c4 /dev-python/python-magic/python-magic-0.4.25.ebuild
parentdev-python/filetype: add 1.0.10 (diff)
downloadgentoo-36ee368becbb62e37e9a548e88e6e9390816c650.tar.gz
gentoo-36ee368becbb62e37e9a548e88e6e9390816c650.tar.bz2
gentoo-36ee368becbb62e37e9a548e88e6e9390816c650.zip
dev-python/python-magic: add 0.4.25
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/python-magic/python-magic-0.4.25.ebuild')
-rw-r--r--dev-python/python-magic/python-magic-0.4.25.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/python-magic/python-magic-0.4.25.ebuild b/dev-python/python-magic/python-magic-0.4.25.ebuild
new file mode 100644
index 000000000000..4b94bfdc2e76
--- /dev/null
+++ b/dev-python/python-magic/python-magic-0.4.25.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Access the libmagic file type identification library"
+HOMEPAGE="https://github.com/ahupp/python-magic"
+SRC_URI="
+ https://github.com/ahupp/python-magic/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-apps/file[-python]"
+BDEPEND="
+ test? ( sys-apps/file )
+"
+
+python_test() {
+ local -x LC_ALL=en_US.UTF-8
+ "${EPYTHON}" test/test.py -v || die "Tests fail with ${EPYTHON}"
+}