summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-08 07:48:44 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-08 07:49:28 +0200
commitaa17a9a4fb560fdb55f21f3fe3781639bd901135 (patch)
tree01a1526c8655ccd8b1bf060c47a474e5f732b5bc /dev-python/python-lsp-jsonrpc
parentdev-python/orjson: Bump to 3.9.6 (diff)
downloadgentoo-aa17a9a4fb560fdb55f21f3fe3781639bd901135.tar.gz
gentoo-aa17a9a4fb560fdb55f21f3fe3781639bd901135.tar.bz2
gentoo-aa17a9a4fb560fdb55f21f3fe3781639bd901135.zip
dev-python/python-lsp-jsonrpc: Bump to 1.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/python-lsp-jsonrpc')
-rw-r--r--dev-python/python-lsp-jsonrpc/Manifest1
-rw-r--r--dev-python/python-lsp-jsonrpc/python-lsp-jsonrpc-1.1.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/python-lsp-jsonrpc/Manifest b/dev-python/python-lsp-jsonrpc/Manifest
index 38ee18a08713..478d74989c6f 100644
--- a/dev-python/python-lsp-jsonrpc/Manifest
+++ b/dev-python/python-lsp-jsonrpc/Manifest
@@ -1 +1,2 @@
DIST python-lsp-jsonrpc-1.0.0.tar.gz 10011 BLAKE2B 671490d439f10eebf2d05f221adad25be6f881f4a0f4fa975d4574937a951d4d0bc51264a9ec67d3ef5d112b6e025b551685d3e3c2b959c4a6bcef92d46c5ff3 SHA512 447835fc6c3810f486d80f85295089c021b792843bdf88d461c021b8b04407d8f7e6a99c07351a23658a5dff46eb475bc64e51bdec029787cd33330b54d4dfec
+DIST python-lsp-jsonrpc-1.1.0.tar.gz 14950 BLAKE2B 061a7c2028d909dcef5a1b1235263fb6909ec6b78c71c210e26403a1c6af351138428e4d3c8360d77d7f0420d27ae9c0f1c0d8aa6bdb645aedd1ca1e85d236d7 SHA512 f62ee2177939a154251bd67f28dd9ce6fdebd39aa1d5e8993676becf7ace074a0397ff1f86c1e91b38bf5f7d06c1d9df5ab7aed00d952534c40999086c4878fe
diff --git a/dev-python/python-lsp-jsonrpc/python-lsp-jsonrpc-1.1.0.ebuild b/dev-python/python-lsp-jsonrpc/python-lsp-jsonrpc-1.1.0.ebuild
new file mode 100644
index 000000000000..68be8217ecf5
--- /dev/null
+++ b/dev-python/python-lsp-jsonrpc/python-lsp-jsonrpc-1.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="JSON RPC 2.0 server library"
+HOMEPAGE="
+ https://github.com/python-lsp/python-lsp-jsonrpc/
+ https://pypi.org/project/python-lsp-jsonrpc/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/ujson-3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pycodestyle[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x TZ=UTC
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts=
+}