summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-11 08:54:28 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-11 09:56:45 +0200
commitf83981c3d263a93e7e74f5a227f52c4b8d12e5df (patch)
tree33a671e84de026f8e3d136d7146e8b54f5d5c28d /dev-python/pytest-timeout
parentdev-python/moto: Bump to 2.2.9 (diff)
downloadgentoo-f83981c3d263a93e7e74f5a227f52c4b8d12e5df.tar.gz
gentoo-f83981c3d263a93e7e74f5a227f52c4b8d12e5df.tar.bz2
gentoo-f83981c3d263a93e7e74f5a227f52c4b8d12e5df.zip
dev-python/pytest-timeout: Bump to 2.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-timeout')
-rw-r--r--dev-python/pytest-timeout/Manifest1
-rw-r--r--dev-python/pytest-timeout/pytest-timeout-2.0.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pytest-timeout/Manifest b/dev-python/pytest-timeout/Manifest
index 52a75dd52a23..c2a35495ad0a 100644
--- a/dev-python/pytest-timeout/Manifest
+++ b/dev-python/pytest-timeout/Manifest
@@ -1 +1,2 @@
DIST pytest-timeout-1.4.2.tar.gz 15424 BLAKE2B b7ab91833e59af56ae50c066c14bb9b8ae9995d1586f35b29f107665d7da124828d7accc1b0149702f2973c61f18024739c68de736ae8aae6f55e8a10bf5d4ff SHA512 3446ecdb5aaad5fbca12df4e7f4f40c6c1a12895d3ed9f3a3ee24800ce36deed3cb8c09a4cc72220c962b06f821cfd55bf7eebbca23664c56abf2d0e5bc8fbea
+DIST pytest-timeout-2.0.0.tar.gz 16210 BLAKE2B 8e3c0436147b6cc680540329daabd7269d301c95663599f7e9c64313bc3a45fde5cc5ea297d5b8c85f43d1a80c2db44b8e150877c3c7b29eef5e38426dfd4efc SHA512 96e9b545b4ac1e4a615863f69d190e0265e85f23dc12df51e9035b8e6bceff23279bb042eed83aa0ddd6d06b0e02a2dcc29ee352fd44cc86f0682fb328264645
diff --git a/dev-python/pytest-timeout/pytest-timeout-2.0.0.ebuild b/dev-python/pytest-timeout/pytest-timeout-2.0.0.ebuild
new file mode 100644
index 000000000000..5be23064f839
--- /dev/null
+++ b/dev-python/pytest-timeout/pytest-timeout-2.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to abort hanging tests"
+HOMEPAGE="https://pypi.org/project/pytest-timeout/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# do not rdepend on pytest, it won't be used without it anyway
+# pytest-cov used to test compatibility
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ !hppa? (
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )
+ )"
+
+distutils_enable_tests --install pytest