summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-17 07:34:32 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-17 07:56:24 +0200
commit3cada3e7b0743d8f358f416eecd4d93fab98d0cf (patch)
tree179a4b13f4b97954ce130c5535462d5f824986fa /dev-python/pytest-timeout
parentdev-python/werkzeug: Remove old (diff)
downloadgentoo-3cada3e7b0743d8f358f416eecd4d93fab98d0cf.tar.gz
gentoo-3cada3e7b0743d8f358f416eecd4d93fab98d0cf.tar.bz2
gentoo-3cada3e7b0743d8f358f416eecd4d93fab98d0cf.zip
dev-python/pytest-timeout: Bump to 1.4.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-timeout')
-rw-r--r--dev-python/pytest-timeout/Manifest1
-rw-r--r--dev-python/pytest-timeout/pytest-timeout-1.4.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pytest-timeout/Manifest b/dev-python/pytest-timeout/Manifest
index fa27ed99f7b5..7f13193f8dc5 100644
--- a/dev-python/pytest-timeout/Manifest
+++ b/dev-python/pytest-timeout/Manifest
@@ -1,2 +1,3 @@
DIST pytest-timeout-1.3.4.tar.gz 12255 BLAKE2B c8991e0255a490048f43e1163d0315cb8fabfaf9d96deb476e2d59da7efce8c63da09b1e8e6f9d6f3fe82b3c6f67608b5e5db117e6378a041ca6e5ba9c71fc05 SHA512 29af25f3c3776d9ef63c6b7217ffc6b0cedd873b8cc96be742a642da84d12c8988bb9b409e00850246e554b21908d6fd2207692650b154cf6831f38c4395bc80
DIST pytest-timeout-1.4.1.tar.gz 13804 BLAKE2B 45e9bdf6eb39e706cac2c9484cd34a9f16096d71d0146251bef9591c35c269043c95e641bed40b25e3d2076fe29a5782363bf9130b331eb04c4e867b1e8f646b SHA512 b62b090365c1cfe1a4d544b5645f828e451ec5229313c50a26ce04ba6cb203ff9ab487c61fb000af342f3d499e11f67aff5f84ff5b00328a129f1f39d4aabf28
+DIST pytest-timeout-1.4.2.tar.gz 15424 BLAKE2B b7ab91833e59af56ae50c066c14bb9b8ae9995d1586f35b29f107665d7da124828d7accc1b0149702f2973c61f18024739c68de736ae8aae6f55e8a10bf5d4ff SHA512 3446ecdb5aaad5fbca12df4e7f4f40c6c1a12895d3ed9f3a3ee24800ce36deed3cb8c09a4cc72220c962b06f821cfd55bf7eebbca23664c56abf2d0e5bc8fbea
diff --git a/dev-python/pytest-timeout/pytest-timeout-1.4.2.ebuild b/dev-python/pytest-timeout/pytest-timeout-1.4.2.ebuild
new file mode 100644
index 000000000000..516df2f00d54
--- /dev/null
+++ b/dev-python/pytest-timeout/pytest-timeout-1.4.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="py.test plugin to abort hanging tests"
+HOMEPAGE="https://pypi.org/project/pytest-timeout/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# do not rdepend on pytest, it won't be used without it anyway
+# pytest-cov used to test compatibility
+BDEPEND="
+ test? (
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ distutils_install_for_testing
+
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}