summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-25 20:19:48 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-25 20:44:59 +0200
commit8024ec5154cc897759379bde7b1dcb863843e6d4 (patch)
treeb5909c4bf8b065c8128ae45e724e8d17295fb710 /dev-python/pytest-subtesthack
parentnet-misc/freerdp: migrate from libav (diff)
downloadgentoo-8024ec5154cc897759379bde7b1dcb863843e6d4.tar.gz
gentoo-8024ec5154cc897759379bde7b1dcb863843e6d4.tar.bz2
gentoo-8024ec5154cc897759379bde7b1dcb863843e6d4.zip
dev-python/pytest-subtesthack: Enable py3.{7,8}, modernize
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-subtesthack')
-rw-r--r--dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild b/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild
index 8de886930db2..87ae193d0678 100644
--- a/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild
+++ b/dev-python/pytest-subtesthack/pytest-subtesthack-0.1.1.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
-PYTHON_COMPAT=( python3_6 )
inherit distutils-r1
DESCRIPTION="A hack for test fixtures, needed for hypothesis inside py.test"
@@ -27,5 +29,5 @@ DEPEND="${RDEPEND}
python_test() {
distutils_install_for_testing
- py.test -v || die "Tests fail with ${EPYTHON}"
+ pytest -vv || die "Tests fail with ${EPYTHON}"
}