summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-23 08:49:04 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-23 09:33:29 +0200
commite2945b2f756738f78c5905bbe7f54a0d14ac8a91 (patch)
tree38a2ee57b83e0fa2e78b4342ea37b4352fb141a4 /dev-python/pytest-subprocess/pytest-subprocess-1.5.0.ebuild
parentmedia-sound/ncspot: allow alsa_backend making pulseaudio optional (diff)
downloadgentoo-e2945b2f756738f78c5905bbe7f54a0d14ac8a91.tar.gz
gentoo-e2945b2f756738f78c5905bbe7f54a0d14ac8a91.tar.bz2
gentoo-e2945b2f756738f78c5905bbe7f54a0d14ac8a91.zip
dev-python/pytest-subprocess: New package, v1.5.0
New dependency for dev-python/scikit-build-core. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-subprocess/pytest-subprocess-1.5.0.ebuild')
-rw-r--r--dev-python/pytest-subprocess/pytest-subprocess-1.5.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pytest-subprocess/pytest-subprocess-1.5.0.ebuild b/dev-python/pytest-subprocess/pytest-subprocess-1.5.0.ebuild
new file mode 100644
index 000000000000..bb2a21146b87
--- /dev/null
+++ b/dev-python/pytest-subprocess/pytest-subprocess-1.5.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A plugin to fake subprocess for pytest"
+HOMEPAGE="
+ https://github.com/aklajnert/pytest-subprocess/
+ https://pypi.org/project/pytest-subprocess/
+"
+SRC_URI="
+ https://github.com/aklajnert/pytest-subprocess/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/pytest-4.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/anyio[${PYTHON_USEDEP}]
+ >=dev-python/docutils-0.12[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.15.1[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p no:flaky
+}