summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-09 18:55:34 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-09 18:55:34 +0200
commit934b04fcc97052ed7fcb95cabe6b7793aa5b2fc4 (patch)
tree268c40fa6f6f9c076c3d876f7b1c1e884ae1dd78 /dev-python/pytest-rerunfailures
parentdev-python/pytest-xdist: Enable py3.13 (diff)
downloadgentoo-934b04fcc97052ed7fcb95cabe6b7793aa5b2fc4.tar.gz
gentoo-934b04fcc97052ed7fcb95cabe6b7793aa5b2fc4.tar.bz2
gentoo-934b04fcc97052ed7fcb95cabe6b7793aa5b2fc4.zip
dev-python/pytest-rerunfailures: Deselect tests failing with pytest-8.2
Closes: https://bugs.gentoo.org/931553 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-rerunfailures')
-rw-r--r--dev-python/pytest-rerunfailures/pytest-rerunfailures-14.0.ebuild12
1 files changed, 12 insertions, 0 deletions
diff --git a/dev-python/pytest-rerunfailures/pytest-rerunfailures-14.0.ebuild b/dev-python/pytest-rerunfailures/pytest-rerunfailures-14.0.ebuild
index fbaa42713a4c..2c7d0538c7c6 100644
--- a/dev-python/pytest-rerunfailures/pytest-rerunfailures-14.0.ebuild
+++ b/dev-python/pytest-rerunfailures/pytest-rerunfailures-14.0.ebuild
@@ -26,6 +26,18 @@ RDEPEND="
distutils_enable_tests pytest
python_test() {
+ local EPYTEST_DESELECT=()
+ if has_version ">=dev-python/pytest-8.2[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ # https://github.com/pytest-dev/pytest-rerunfailures/issues/267
+ tests/test_pytest_rerunfailures.py::test_exception_match_only_rerun_in_dual_query
+ tests/test_pytest_rerunfailures.py::test_exception_matches_only_rerun_query
+ tests/test_pytest_rerunfailures.py::test_exception_matches_rerun_except_query
+ tests/test_pytest_rerunfailures.py::test_exception_not_match_rerun_except_query
+ tests/test_pytest_rerunfailures.py::test_run_session_teardown_once_after_reruns
+ )
+ fi
+
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
local -x PYTEST_PLUGINS=pytest_rerunfailures
epytest