summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-07-01 20:55:05 +0200
committerMatt Turner <mattst88@gentoo.org>2020-07-16 21:13:52 -0700
commita7a19400c46fa09e8cc70e79140a5ffe5a3cadb9 (patch)
treeed758c6c08ea536b91ecfc41254fd86758f334ee /dev-python/pytest-pep8
parentdev-python/pytest-cache: add py3_8,9 rem py2,3_6 (diff)
downloadgentoo-a7a19400c46fa09e8cc70e79140a5ffe5a3cadb9.tar.gz
gentoo-a7a19400c46fa09e8cc70e79140a5ffe5a3cadb9.tar.bz2
gentoo-a7a19400c46fa09e8cc70e79140a5ffe5a3cadb9.zip
dev-python/pytest-pep8: add py3_8 rem py2,3_6
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/pytest-pep8')
-rw-r--r--dev-python/pytest-pep8/pytest-pep8-1.0.6-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pytest-pep8/pytest-pep8-1.0.6-r2.ebuild b/dev-python/pytest-pep8/pytest-pep8-1.0.6-r2.ebuild
new file mode 100644
index 000000000000..141399f020e7
--- /dev/null
+++ b/dev-python/pytest-pep8/pytest-pep8-1.0.6-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} pypy3 )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin to check PEP8 requirements"
+HOMEPAGE="https://pypi.org/project/pytest-pep8/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/pep8-1.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.4.2[${PYTHON_USEDEP}]
+ dev-python/pytest-cache[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/1.0.6-MANIFEST.patch
+)
+
+python_test() {
+ ${EPYTHON} test_pep8.py || die
+}