summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-06 10:13:59 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-06 10:18:41 +0200
commit8d63b982dab9b71d18dfce83463346069f26177c (patch)
tree802702e78d68400995c4e25daa30a2895bb1e299 /dev-python/pytest-localserver
parentdev-java/univocity-parsers: Stabilize 2.9.1 arm64, #842855 (diff)
downloadgentoo-8d63b982dab9b71d18dfce83463346069f26177c.tar.gz
gentoo-8d63b982dab9b71d18dfce83463346069f26177c.tar.bz2
gentoo-8d63b982dab9b71d18dfce83463346069f26177c.zip
dev-python/pytest-localserver: Bump to 0.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-localserver')
-rw-r--r--dev-python/pytest-localserver/Manifest1
-rw-r--r--dev-python/pytest-localserver/pytest-localserver-0.6.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pytest-localserver/Manifest b/dev-python/pytest-localserver/Manifest
index 475283bcdf74..a716f6e6f01e 100644
--- a/dev-python/pytest-localserver/Manifest
+++ b/dev-python/pytest-localserver/Manifest
@@ -1 +1,2 @@
DIST pytest-localserver-0.5.1.tar.gz 19341 BLAKE2B 759a90552b6f950579088a7c41448ad0f000aab980c56361d0e1a40d98a00ee234bf542a6309eb096602536da3fa819b7227a962d0592a801131a019f1617cdc SHA512 dad8b21020cf2f08ad03398b82bad7b47e553a9c6b489b94186bdc61c22f57e7151f8dbeab38ef42d03658104ec42920ec363288a1bdbea34dab6aee1da03c48
+DIST pytest-localserver-0.6.0.tar.gz 182346 BLAKE2B b8f56c6db3bc9c260c747cdf707aac0de22152111d3a8f9c0ea8adb8e5e556edf4a1ffa0d4fd517bf95428c69ebc0c1629a103c3b8f44a57b939f696cb9240cd SHA512 149796393af260fa5d69560852e9d11b569515b8486859302af2ed369a93bbb7cad11f54210851bd4030d8f7f5936a0306fe9599bc8477bdfc61d3d0a83cb205
diff --git a/dev-python/pytest-localserver/pytest-localserver-0.6.0.ebuild b/dev-python/pytest-localserver/pytest-localserver-0.6.0.ebuild
new file mode 100644
index 000000000000..809e2e45c873
--- /dev/null
+++ b/dev-python/pytest-localserver/pytest-localserver-0.6.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pytest plugin to test server connections locally"
+HOMEPAGE="https://pypi.org/project/pytest-localserver/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/werkzeug-0.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # requires aiosmtpd that is dead and broken beyond repair
+ tests/test_smtp.py
+)