summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-31 06:05:09 +0200
committerMichał Górny <mgorny@gentoo.org>2023-03-31 06:05:09 +0200
commitff03809aa52920d4c4f65b40bc699c9cefcc6704 (patch)
tree305c0246e85e7e539b7500ad2c1e29b10bcc0015 /dev-python/pytest-jupyter
parentdev-python/pydata-sphinx-theme: Bump to 0.13.3 (diff)
downloadgentoo-ff03809aa52920d4c4f65b40bc699c9cefcc6704.tar.gz
gentoo-ff03809aa52920d4c4f65b40bc699c9cefcc6704.tar.bz2
gentoo-ff03809aa52920d4c4f65b40bc699c9cefcc6704.zip
Rename dev-python/{pytest_jupyter → pytest-jupyter}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-jupyter')
-rw-r--r--dev-python/pytest-jupyter/Manifest1
-rw-r--r--dev-python/pytest-jupyter/metadata.xml17
-rw-r--r--dev-python/pytest-jupyter/pytest-jupyter-0.6.2.ebuild30
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/pytest-jupyter/Manifest b/dev-python/pytest-jupyter/Manifest
new file mode 100644
index 000000000000..6baef7011d27
--- /dev/null
+++ b/dev-python/pytest-jupyter/Manifest
@@ -0,0 +1 @@
+DIST pytest_jupyter-0.6.2.tar.gz 15174 BLAKE2B b6c536383ab1b8e375e4250b4922ac6372f850ee4993643122896092109d3f711f91ccc7b159b7330de18f7876df818dc01d31c05e3c18d97488255e063db4d4 SHA512 396f7a7c978097e6dee37ead92bb3c8cef2a8100a7cc85b0b1eab19e20bdaed3332391c17568a6a279ab6ddeea1fbb2fa8dafe24ba4500982ba52cfcda2b1052
diff --git a/dev-python/pytest-jupyter/metadata.xml b/dev-python/pytest-jupyter/metadata.xml
new file mode 100644
index 000000000000..8d9f695ec9a1
--- /dev/null
+++ b/dev-python/pytest-jupyter/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pytest-jupyter</remote-id>
+ <remote-id type="github">jupyter-server/pytest-jupyter</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-jupyter/pytest-jupyter-0.6.2.ebuild b/dev-python/pytest-jupyter/pytest-jupyter-0.6.2.ebuild
new file mode 100644
index 000000000000..d19d19f131bd
--- /dev/null
+++ b/dev-python/pytest-jupyter/pytest-jupyter-0.6.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pytest plugin for testing Jupyter libraries and extensions"
+HOMEPAGE="https://jupyter.org"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="
+ >=dev-python/jupyter_client-7.4.0[${PYTHON_USEDEP}]
+ >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-1.21[${PYTHON_USEDEP}]
+ >=dev-python/nbformat-5.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest