summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-22 13:54:15 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-22 14:15:33 +0200
commit281793ff244615bc5a183c62b9ed39d442a6a16c (patch)
tree670aab649224a3da59b7279c6703325dcf027b18 /dev-python/pytest-httpserver
parentdev-python/PyPDF2: Bump to 2.10.9 (diff)
downloadgentoo-281793ff244615bc5a183c62b9ed39d442a6a16c.tar.gz
gentoo-281793ff244615bc5a183c62b9ed39d442a6a16c.tar.bz2
gentoo-281793ff244615bc5a183c62b9ed39d442a6a16c.zip
dev-python/pytest-httpserver: Bump to 1.0.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-httpserver')
-rw-r--r--dev-python/pytest-httpserver/Manifest1
-rw-r--r--dev-python/pytest-httpserver/pytest-httpserver-1.0.6.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pytest-httpserver/Manifest b/dev-python/pytest-httpserver/Manifest
index 60ec99968c1e..abf39ebef705 100644
--- a/dev-python/pytest-httpserver/Manifest
+++ b/dev-python/pytest-httpserver/Manifest
@@ -1 +1,2 @@
DIST pytest-httpserver-1.0.5.gh.tar.gz 80395 BLAKE2B 68c075032c57f25854d390f73bf61b7efbe18f78d7f0b2a2a3be10d586ca9cc3ce4a1b390a2ba0da1e88558513782388069c419dae4908a0581e8d583f452bee SHA512 8275475bb044d54769e906571520fafbb9f6fa32fc003f4a00f72b9ff9930e4b80ee84564df1521569cc2a15f5d371c6315129263bc167d0621141004d509a25
+DIST pytest-httpserver-1.0.6.gh.tar.gz 83737 BLAKE2B d0db97227bcb3336a4bd944cf26e2d3e96132baee5991cdff901a1f546174e977b6472458911fc6b92bb13b6d3dae499e0bf3507be265385601e838c4781f0a3 SHA512 5eacfbf159f3a09d73f54da8f3ff885b8d2138e430af27df6039a30e63d7ebcbcf088efe8e7fa56ed50b66ea5b7e3ad7a61c0e8a57d5cb100c2a063df7b6f5c4
diff --git a/dev-python/pytest-httpserver/pytest-httpserver-1.0.6.ebuild b/dev-python/pytest-httpserver/pytest-httpserver-1.0.6.ebuild
new file mode 100644
index 000000000000..326f3d0b4625
--- /dev/null
+++ b/dev-python/pytest-httpserver/pytest-httpserver-1.0.6.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP server for pytest to test HTTP clients"
+HOMEPAGE="
+ https://github.com/csernazs/pytest-httpserver/
+ https://pypi.org/project/pytest-httpserver/
+"
+SRC_URI="
+ https://github.com/csernazs/pytest-httpserver/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/requests[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p no:localserver
+}