summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-30 21:13:40 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-30 22:00:30 +0100
commit40ce7e923ae7e606a5347c30db8a3295dd171fe9 (patch)
tree734c269da56aa1dc2365943fdde8bad06f16aad8 /dev-python/pytest-cov
parentdev-python/django-tables2: drop old version (diff)
downloadgentoo-40ce7e923ae7e606a5347c30db8a3295dd171fe9.tar.gz
gentoo-40ce7e923ae7e606a5347c30db8a3295dd171fe9.tar.bz2
gentoo-40ce7e923ae7e606a5347c30db8a3295dd171fe9.zip
dev-python/pytest-cov: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pytest-cov')
-rw-r--r--dev-python/pytest-cov/Manifest1
-rw-r--r--dev-python/pytest-cov/files/pytest-cov-2.8.1-disable-broken-tests.patch20
-rw-r--r--dev-python/pytest-cov/files/pytest-cov-2.8.1-latest-setuptools.patch40
-rw-r--r--dev-python/pytest-cov/files/pytest-cov-2.8.1-python38.patch52
-rw-r--r--dev-python/pytest-cov/pytest-cov-2.8.1.ebuild51
5 files changed, 0 insertions, 164 deletions
diff --git a/dev-python/pytest-cov/Manifest b/dev-python/pytest-cov/Manifest
index 59e6aad01258..7328fa1a0dff 100644
--- a/dev-python/pytest-cov/Manifest
+++ b/dev-python/pytest-cov/Manifest
@@ -1,4 +1,3 @@
DIST pytest-cov-2.10.1.tar.gz 56822 BLAKE2B 45eba205a2c6687882445d3554cedc04ad556854f5eac8eb0fab7fda84cdf2736b034dfdceb664293d1add153a5271403eb94585a863676ccfef9ab09727d165 SHA512 2dd575141754a417f34b414ba7e07291c273abdc63a6b7dc72d317c6ec10076b83c2ad78eeefdda7cee1fd6f56932d838602da4dd760a1c0d12095be94c22568
DIST pytest-cov-2.11.0.tar.gz 59018 BLAKE2B f2ecaff439e701c3b7d029e4c51cb019d5222a083815ae5771341b0fa0f1b658f921a6eab75c0b568b630cc7ca75887f25ae7fb6fcaa9c2e8dc419397c4c799a SHA512 001f4975d7ad1a573354074366f983887ec9035bcc29afe9bd1ae2654fab520b8f479c5037936e6131749e5205077e937304e73d366cb43460db1f24a58b02be
DIST pytest-cov-2.11.1.tar.gz 59143 BLAKE2B 21aeffbc9ccbe6a7c69a08fe3f0013204eb039c6dc9ddbb364a74ad10764e16ce7be0154e27beaab2c8f9b2a972131c4c2421c4aa4557efc18318556056a421b SHA512 19c465f5972ee0ee3b9a2f1a656fdf5457622cb449f73a6f707d377a617807dadda997a6875f0c081bc4c4f7039559c6e7ce820b818db42dfd053c016e1c3b4e
-DIST pytest-cov-2.8.1.tar.gz 47661 BLAKE2B 590fd50b69d01a71b20982d8cdbed0698ebe24c290d791bb44c96aa1aaaf77cf1f379d565eb775864c6945facf6d271115236cb44b95e4a4c9bb7cc6fd591acf SHA512 769a17c2095dbe990df148a0105c9e3dc88ac2265ac77ac31448dab6abf6d8cc0d54f5c6ff01fd708bd38700bfea93f57d3bb702bd9bb0a708257d094b2376ec
diff --git a/dev-python/pytest-cov/files/pytest-cov-2.8.1-disable-broken-tests.patch b/dev-python/pytest-cov/files/pytest-cov-2.8.1-disable-broken-tests.patch
deleted file mode 100644
index 660db5e59431..000000000000
--- a/dev-python/pytest-cov/files/pytest-cov-2.8.1-disable-broken-tests.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff --git a/tests/test_pytest_cov.py b/tests/test_pytest_cov.py
-index e79e9aa..e5ef2c1 100644
---- a/tests/test_pytest_cov.py
-+++ b/tests/test_pytest_cov.py
-@@ -820,6 +820,7 @@ parallel = true
- assert result.ret == 0
-
-
-+@pytest.mark.skip(reason="test is broken")
- def test_central_subprocess_change_cwd_with_pythonpath(testdir, monkeypatch):
- stuff = testdir.mkdir('stuff')
- parent_script = stuff.join('parent_script.py')
-@@ -951,6 +952,7 @@ def test_invalid_coverage_source(testdir):
- assert not matching_lines
-
-
-+@pytest.mark.skip(reason="test is broken")
- @pytest.mark.skipif("'dev' in pytest.__version__")
- @pytest.mark.skipif('sys.platform == "win32" and platform.python_implementation() == "PyPy"')
- def test_dist_missing_data(testdir):
diff --git a/dev-python/pytest-cov/files/pytest-cov-2.8.1-latest-setuptools.patch b/dev-python/pytest-cov/files/pytest-cov-2.8.1-latest-setuptools.patch
deleted file mode 100644
index 8a9618c3fd98..000000000000
--- a/dev-python/pytest-cov/files/pytest-cov-2.8.1-latest-setuptools.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 1305b23..3a5803e 100644
---- a/setup.py
-+++ b/setup.py
-@@ -29,7 +29,7 @@ def read(*names, **kwargs):
-
-
- class BuildWithPTH(build):
-- def run(self):
-+ def run(self, **kwargs):
- build.run(self)
- path = join(dirname(__file__), 'src', 'pytest-cov.pth')
- dest = join(self.build_lib, basename(path))
-@@ -37,7 +37,7 @@ class BuildWithPTH(build):
-
-
- class EasyInstallWithPTH(easy_install):
-- def run(self):
-+ def run(self, **kwargs):
- easy_install.run(self)
- path = join(dirname(__file__), 'src', 'pytest-cov.pth')
- dest = join(self.install_dir, basename(path))
-@@ -45,7 +45,7 @@ class EasyInstallWithPTH(easy_install):
-
-
- class InstallLibWithPTH(install_lib):
-- def run(self):
-+ def run(self, **kwargs):
- install_lib.run(self)
- path = join(dirname(__file__), 'src', 'pytest-cov.pth')
- dest = join(self.install_dir, basename(path))
-@@ -57,7 +57,7 @@ class InstallLibWithPTH(install_lib):
-
-
- class DevelopWithPTH(develop):
-- def run(self):
-+ def run(self, **kwargs):
- develop.run(self)
- path = join(dirname(__file__), 'src', 'pytest-cov.pth')
- dest = join(self.install_dir, basename(path))
diff --git a/dev-python/pytest-cov/files/pytest-cov-2.8.1-python38.patch b/dev-python/pytest-cov/files/pytest-cov-2.8.1-python38.patch
deleted file mode 100644
index 6292672b6191..000000000000
--- a/dev-python/pytest-cov/files/pytest-cov-2.8.1-python38.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-diff --git a/tests/test_pytest_cov.py b/tests/test_pytest_cov.py
-index e79e9aa..198478b 100644
---- a/tests/test_pytest_cov.py
-+++ b/tests/test_pytest_cov.py
-@@ -662,6 +662,7 @@ def test_fail(p):
- ])
-
-
-+@pytest.mark.skipif("sys.hexversion >= 0x3080000", reason="Seems buggy on python3.8")
- @pytest.mark.skipif('sys.platform == "win32" or platform.python_implementation() == "PyPy"')
- def test_dist_combine_racecondition(testdir):
- script = testdir.makepyfile("""
-@@ -1018,6 +1019,7 @@ def test_funcarg_not_active(testdir):
- assert result.ret == 0
-
-
-+@pytest.mark.skipif("sys.hexversion >= 0x3080000", reason="https://bugs.python.org/issue38227")
- @pytest.mark.skipif("sys.version_info[0] < 3", reason="no context manager api on Python 2")
- @pytest.mark.skipif('sys.platform == "win32"', reason="multiprocessing support is broken on Windows")
- @pytest.mark.skipif('platform.python_implementation() == "PyPy"', reason="often deadlocks on PyPy")
-@@ -1059,6 +1061,7 @@ def test_run_target():
- assert result.ret == 0
-
-
-+@pytest.mark.skipif("sys.hexversion >= 0x3080000", reason="https://bugs.python.org/issue38227")
- @pytest.mark.skipif('sys.platform == "win32"', reason="multiprocessing support is broken on Windows")
- @pytest.mark.skipif('platform.python_implementation() == "PyPy"', reason="often deadlocks on PyPy")
- def test_multiprocessing_pool_terminate(testdir):
-@@ -1141,6 +1144,7 @@ def test_run_target():
- assert result.ret == 0
-
-
-+@pytest.mark.skipif("sys.hexversion >= 0x3080000", reason="https://bugs.python.org/issue38227")
- @pytest.mark.skipif('sys.platform == "win32"', reason="multiprocessing support is broken on Windows")
- def test_multiprocessing_process(testdir):
- pytest.importorskip('multiprocessing.util')
-@@ -1171,6 +1175,7 @@ def test_run_target():
- assert result.ret == 0
-
-
-+@pytest.mark.skipif("sys.hexversion >= 0x3080000", reason="https://bugs.python.org/issue38227")
- @pytest.mark.skipif('sys.platform == "win32"', reason="multiprocessing support is broken on Windows")
- def test_multiprocessing_process_no_source(testdir):
- pytest.importorskip('multiprocessing.util')
-@@ -1201,6 +1206,7 @@ def test_run_target():
- assert result.ret == 0
-
-
-+@pytest.mark.skipif("sys.hexversion >= 0x3080000", reason="https://bugs.python.org/issue38227")
- @pytest.mark.skipif('sys.platform == "win32"', reason="multiprocessing support is broken on Windows")
- def test_multiprocessing_process_with_terminate(testdir):
- pytest.importorskip('multiprocessing.util')
diff --git a/dev-python/pytest-cov/pytest-cov-2.8.1.ebuild b/dev-python/pytest-cov/pytest-cov-2.8.1.ebuild
deleted file mode 100644
index 960f0686259e..000000000000
--- a/dev-python/pytest-cov/pytest-cov-2.8.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{6..9} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="py.test plugin for coverage reporting"
-HOMEPAGE="https://github.com/pytest-dev/pytest-cov https://pypi.org/project/pytest-cov/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~mips ppc ppc64 ~riscv s390 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/py-1.4.22[${PYTHON_USEDEP}]
- >=dev-python/pytest-3.6[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.4[${PYTHON_USEDEP}]
-"
-DEPEND="
- test? (
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-python/fields[${PYTHON_USEDEP}]
- >=dev-python/process-tests-2.0.2[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- # Bug 597708
- "${FILESDIR}/${PN}-2.8.1-disable-broken-tests.patch"
- "${FILESDIR}/${PN}-2.8.1-latest-setuptools.patch"
- # https://github.com/pytest-dev/pytest-cov/issues/365
- "${FILESDIR}/pytest-cov-2.8.1-python38.patch"
-)
-
-distutils_enable_sphinx docs \
- dev-python/sphinx-py3doc-enhanced-theme
-
-python_test() {
- distutils_install_for_testing
- PYTHONPATH="${S}/tests:${BUILD_DIR}/lib:${PYTHONPATH}" \
- PYTEST_PLUGINS=${PN/-/_} \
- pytest -vv || die "Tests failed under ${EPYTHON}"
-}